Nertman45
?>

Впаскале напишите программу, которая вводит с клавиатуры трёхзначное число и находит разность между трёхзначным числом и числом, составленных из тех же цифр, но взятых в обратном порядке. вывести на экран обратное число и полученную разность. например, из числа 123 должно получиться число 321 и -198. строки не использовать ​

Информатика

Ответы

Panfilov_Anna
  program proga_25_1;
 Var
A: text;     
i,j,n,m : byte;     
 d: string;     
Sim:char;
 Begin             
write('Введите имя текстового файла   ');  {Например: "test" он создастся там где находится сама программа }               
read(d);                                       
 Assign(A,d);               
 rewrite(A);                   
 write('Введите количество строк: N= ');                        
readln(n);                   
 write('Введите количество символов в строке: M= ');                     
  readln(m);                                     
for I:=1 to n do                   
 begin                         
 Sim:=Chr(Ord('1')+I-1);                         
  For J:=1 to m do                             
  write(A,Sim);                               
 writeln(A);                 
  end;                         
  close(A);
end.     
leonid-adv70
Program proga;
Var  
p: text;   
  i, n : byte;     
 s,min,m: string;     
 Begin                         
 write('Введите имя файла   ');  {Например: C:.txt}                         
 read(m);
Assign(p,m);      
  reset(p);
    read(p,s);
 min:=s;   
 n:=100;   
 for i:=1 to n do   
 begin     
readln(p,s);                                      
while not eof(p) do  
 {нахождение минимальной строки}       
   begin         
 readln(p,s);       
   if length(s) <= length(min) then        
  min:=s;         
 end;          
 end;
close(p);   
 write('самая короткая строка: ',min);
End.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Впаскале напишите программу, которая вводит с клавиатуры трёхзначное число и находит разность между трёхзначным числом и числом, составленных из тех же цифр, но взятых в обратном порядке. вывести на экран обратное число и полученную разность. например, из числа 123 должно получиться число 321 и -198. строки не использовать ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Tatyana1374
galinab1111326
mursvita943
Aleksandrova Zhanna1250
avdeevau807
samsakovs7757
komarov-dmitriy
lepekhov4011
Boldinova-Marianna
Kuznetsova702
yocrew13
Golovinskii_Sirotkina1944
stsnab
Salko17
raa-0485428