?>
Boolean составить программу, печатающую значение true, если указанное высказывание является истинным, и false в противном случае: 1) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр; 2) с�мма цифр данного трехзначного числа n является четным числом; 3) точка с координатами (х, у) принадлежит части плоскости, лежащей между прямыми x = m, x = n (m < n); 4) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа; 5) целое число n является четным двузначным числом; 6) треугольник со сторонами а, b, c является равносторонним; 7) треугольник со сторонами а, b, c является равнобедренным; 8) среди чисел a, b, c есть хотя бы одна пара взаимно противоположных чисел; 9) числа c и b выражают длины катетов одного прямоугольного треугольника, а c и d – другого. эти треугольники являются подобными; 10) даны три стороны одного и три стороны другого треугольника. эти треугольники равновеликие, т.е. имеют равные площади; 11) данная тройка натуральных чисел a, b, c является тройкой пифагора, т.е. c2 = a2 + b2; 12) все цифры данного четырехзначного числа n различны; 13) данные числа x, y являются координатами точки, лежащей в первой координатной четверти; 14) (х1, у1) и (х2, у2) – координаты левой верхней и правой нижней вершин прямоугольника; точка а(х, у) лежит внутри этого прямоугольника или на одной из его сторон; 15) число с является средним арифметическим чисел a и b; 16) натуральное число n является точным квадратом; 17) цифры данного четырехзначного числа n образуют строго возрастающую последовательность; 18) цифры данного трехзначного числа n являются членами арифметической прогрессии; 19) цифры данного трехзначного числа n являются членами прогрессии; 20) данные числа c и d являются соответственно квадратом и кубом числа а; 21) цифра м входит в десятичную запись четырехзначного числа n; 22) данное четырехзначное число читается одинаково слева направо и справа налево; 23) сумма двух натуральных чисел кратна 2; 24) произведение натуральных чисел a и b кратно числу с; 25) сумма двух действительных чисел a и b является целым числом, т.е. дробная часть суммы равна нулю; 26) данное натуральное число а кратно числу b, но не кратно числу с.
Ответы
handsfree = true;
var
a: array[1..100] of real;
i, n: integer;
min, max: real;
k: integer;
begin
{ввод массива}
if handsfree then
n := random(20) + 5
else begin
write('n = ');
readln(n);
end;
writeln('Данные массива:');
for i := 1 to n do
begin
if handsfree then begin
a[i] := random(100);
write(a[i], ' ');
end
else readln(a[i]);
end;
writeln();
{подсчет элементов}
k := 0;
for i := 1 to n do
if a[i] > 5 then k := k + 1;
writeln(k);
end.