Поделитесь своими знаниями, ответьте на вопрос:
Как написать программу на питоне? андрей готовился к егэ по информатике и встретил в демо-версии егэ 2015 года такую : автомат получает на вход четырёхзначное число. по этому числу строится новое число по следующим правилам.1. складываются первая и вторая, а также третья и четвёртая цифры исходного числа.2. полученные два числа записываются друг за другом в порядке убывания (без разделителей), пример. исходное число: 3165. суммы: 3+1 = 4 6+5 = 11. результат. 114.укажите наименьшее число, в результате обработки которого автомат выдаст число 1311.андрей решил, что для самопроверки он напишет программу, которая решает подобную . мы думаем, что вы тоже с этим справитесь.программа получает на вход некоторое натуральное число n, которое может содержать две, три или четыре цифры.программа должна вывести такое наименьшее целое четырёхзначное число к, после применения к которому описанного выше алгоритма получается число v. если же такого числа не существует, программадолжна вывести число 0.примерывходные данные1311выходные данные2949
program expression;
var
x, y: real;
begin
read(x);
y := power(x, 4) - 3 * power(x, 3) + 5 * x - 6;
write(y);
end.
Объяснение:
program expression; // Название программы
var
x, y: real; // Две переменные являются вещественными (требуется для power)
begin // Начало программы
read(x); // Вводим число с клавиатуры
y := power(x, 4) - 3 * power(x, 3) + 5 * x - 6; // Само выражение
power(число, которое нужно возвести в степень | сама степень)
power(x, 4)
x - число
4 - степень
write(y); // Выводим ответ
end. // Начало программы