ostapbender1111
?>

Слова и буквы ограничение времени 1 секунда ограничение памяти 64mb ввод стандартный ввод или input.txt вывод стандартный вывод или output.txt напишите программу, которая считывает слова, слово «стоп» — сигнал остановки (оно не должно принимать участие в анализе из введённых слов нужно выбрать самое длинное и самое короткое (гарантируется, что все они имеют разную длину) и проверить, есть ли все буквы короткого слова в длинном, при этом количество повторений букв не учитывается. вывести «да» или «нет» в зависимости от этого. формат ввода слова разной длины, из которых нужно выбрать кратчайшее и длиннейшее. после этих слов следует слово «стоп». формат вывода да или нет пример 1 ввод вывод грот вигвам гаррота стоп да пример 2 ввод вывод чаепитие чашка печенье стоп нет пример 3 ввод вывод чечевица светопреставление престол стоп да язык программирования - pyton !

Информатика

Ответы

afoninia

Это что бы найти наименьшие и наибольшие по длине слово

Объяснение:

answer = ""

max1, min1 = 0, 1000000000000000

max2, min2 = "", ""

while answer != "стоп":

   answer = input()

   k = len(answer)

   if k > max1:

       max2 = answer

       max1 = k

   if k < min1:

       min2 = answer

       min1 = k

print(min2)

print(max2)

suhanowaswetlana

В алфавитах ориентироваться легко: смотрим сколько цифр используется такое будет и название

0,1,2,3 - 4 цифры система счисления называется четверичная

0,1,2,3,4,5  - 6 цифр система счисления называется шестеричная

0,1,2,3,4,5,6,7,8  - 9 цифр система счисления называется девятеричная

0,1,2,3,4,5,6,7,8 ,9,А,В - 12 цифр система счисления называется двенадцатеричная (это если выписаны правильно все буквы и больше нет никаких. В случае, если есть ещё буквы C,D,E,F - СИСТЕМА СЧИСЛЕНИЯ БУДЕТ НАЗЫВАТЬСЯ ШЕСТНАДЦАТЕРИЧНАЯ)


Алексей Кирилл1094
Const
    handsfree = false;

var
    a: array[1..100] of integer;
    i, n: integer;

begin
    {ввод массива}
    if handsfree then
        n := random(20) + 5
    else begin
        write('n = ');
        readln(n);
    end;
    
    writeln('Данные массива:');
    for i := 1 to n do
    begin
        if handsfree then begin
            a[i] := random(100) - 50;
            write(a[i], ' ');
        end
        else readln(a[i]);
    end;
    writeln();
    
    {изменение элементов}
    writeln('Вывод прямой:');
    for i := 1 to n do
        write(a[i], ' ');
    writeln();
    
        {изменение элементов}
    writeln('Вывод обратный:');
    for i := n downto 1 do
        write(a[i], ' ');
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Слова и буквы ограничение времени 1 секунда ограничение памяти 64mb ввод стандартный ввод или input.txt вывод стандартный вывод или output.txt напишите программу, которая считывает слова, слово «стоп» — сигнал остановки (оно не должно принимать участие в анализе из введённых слов нужно выбрать самое длинное и самое короткое (гарантируется, что все они имеют разную длину) и проверить, есть ли все буквы короткого слова в длинном, при этом количество повторений букв не учитывается. вывести «да» или «нет» в зависимости от этого. формат ввода слова разной длины, из которых нужно выбрать кратчайшее и длиннейшее. после этих слов следует слово «стоп». формат вывода да или нет пример 1 ввод вывод грот вигвам гаррота стоп да пример 2 ввод вывод чаепитие чашка печенье стоп нет пример 3 ввод вывод чечевица светопреставление престол стоп да язык программирования - pyton !
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

pavlovm8316
targovich
bochkarevazh
vlebedeva81
Новиков1139
ekaterinkat
bestform
bagramyansvetlana
dmitzu8594
Petrovich
ElenaSkvortsova2
Letajushaya362
kapustina198690
infooem
kristinagaspa62