sav4ukoxana7149
?>

1) напишите программу, которая организует массив из 10 целых чисел по случайному закону в интервале от 0 до 200. и определяет сумму элементов массива кратных 5. на экран выводятся элементы созданного массива в строку с форматом 4, элементы , значение которых кратно 5 и сумма. используйте 2 цикла.

Информатика

Ответы

frsergeysavenok

var

 a: array [1..10] of Integer;

 i, s: Integer;

begin

 Randomize;

 s := 0;

 for i := Low (a) to High (a) do begin

   a [i] := Random (201);

   Write (a [i] :4);

 end;

 WriteLn;

 for i := Low (a) to High (a) do begin

   if a [i] mod 5 = 0 then begin

     s := s + a [i];

     Write (a [i] :4);

   end;

 end;

 WriteLn;

 WriteLn ('Сумма = ', s);

 ReadLn;

end.

Vitalevna

Информация - это любые сведения, принимаемые и передаваемые, сохраняемые различными источниками. Информация - это вся совокупность сведений об окружающем нас мире, о всевозможных протекающих в нем процессах, которые могут быть восприняты живыми организмами, электронными машинами и другими информационными системами.

Первоначально сведения получают при органов чувств – зрения, слуха, обоняния, вкуса и осязания. Для передачи информации на ближнем расстоянии существует язык, который позволяет сообщить полученные сведения другому человеку. Кроме того, передать что-либо другому человеку можно, написав письмо либо в процессе спектакля, а также при разговоре по телефону. Несмотря на то, что в последнем примере используется средство связи, то есть промежуточное устройство, оно позволяет передать сведения в непосредственном контакте.

Для передачи данных от человека к компьютеру необходимо введение ее в память устройства. Информация может иметь разный вид, о чем будет идти разговор далее.

Передача от компьютера к компьютеру происходит посредством промежуточных устройств (флеш-карты, интернета, диска и т. д.).

#телефон, компьютер и тд

buhtovarish

Короче. Вот код.

def matrix_gen(gen, n, m):    Matrix = [];    for i in range(n):        a = [];        for j  in range(m):            a.append(gen[j]);        Matrix.append(a);    return Matrix;

Объяснение

Сначало ты инициализируешь функицю с названием "matrix_gen", которая принимает 3 параметра, 'gen' -- это генератор которые ты будешь использовать. 'n' & 'm' это размер матрицы.

Второй строчкой ты инициалихируешь пустой массив, которые похже заполнишь. Третей строчкой ты в for цикле обходишь все строки матрицы, они же подмассивы массива  Matrix, просто 'a'. Делаем мы это 'n' раз.

Четвётрой строчкой ты инициализируешь массив(ы, мы в цикле) 'a', и следующей строчкой заполняешь уже его. Так же в for цикле. Всего в нём будет 'm' элементов.

Надеюсь решение правильное. Честно говоря у тебя вопрос очень странно поставлен.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1) напишите программу, которая организует массив из 10 целых чисел по случайному закону в интервале от 0 до 200. и определяет сумму элементов массива кратных 5. на экран выводятся элементы созданного массива в строку с форматом 4, элементы , значение которых кратно 5 и сумма. используйте 2 цикла.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

sergeystepanov231
expozition
Avdimov5
Advantage9111
tanyashevvvv
Kashtanov Anna
vera141187
Tadevosyan
Староческуль-Станиславовна
Чему равна основание 8-ричной системы счисления
aaazovcev
Chuhnin195107364
Бочкарева Горохова1652
marinarodina90
zuzazuza61
pronikov90