kotsur
?>

100 . напишите программу на паскале седьмое обратный корень эта настолько проста, что авторы даже поленились сочинить для нее условие! формат входных данных входной поток содержит набор целых чисел ai (0 ≤ ai ≤ 1018), отделённых друг от друга произвольным количеством пробелов и переводов строк. размер входного потока не превышает 256 кб. формат результата для каждого числа ai, начиная с последнего и заканчивая первым, в отдельной строке вывести его квадратный корень не менее чем с четырьмя знаками после десятичной точки. примеры входные данные 1427 0 876652098643267843 5276538 результат работы 2297.0716 936297014.1164 0. 37.7757

Информатика

Ответы

Letajushaya362

ответ:

извини не смог решить соряр

Bogataya Vladimir318
1)var a:array[1..4,1..4] of integer;
      i,j,s:integer;
begin
      for i:=1 to 4 do
         for j:=1 to 4 do 
               readln(a[i,j]);
         
           for i:=1 to 4 do begin 
                     writeln();
                   for j:=1 to 4 do begin 
                     write(a[i,j],' '); 
                    if (i+j>5) then s:=s+a[i,j];
                        end;
                 end;
writeln();
write(s);
end.

2)var a:array[1..4,1..4] of integer;
      i,j,s:integer;
begin
      for i:=1 to 4 do
         for j:=1 to 4 do 
               readln(a[i,j]);
         
           for i:=1 to 4 do begin 
                     writeln();
                   for j:=1 to 4 do begin 
                     write(a[i,j],' '); 
                    if (i>J) then s:=s+a[i,j];
                        end;
                 end;
writeln();
write(s);
end.
Bologova Golovach1989
var  mas1, mas2: array[0..9] of integer;  t, k, i, j: integer; 
begin  
readln(t);  
readln(k);  
for j := 0 to 1 do  begin   
      if (j = 1) then writeln();        
                 for i := 0 to 9 do    begin      
                          if(j = 0) then begin       
                                  mas1[i] := random(100);        
                                    write(mas1[i], ' ');       
                                    if mas1[i] > t Then mas1[i] := mas1[i] + 4;      
                              end      
                            else 
                               begin       
                                      mas2[i] := random(100);        
                                      write(mas2[i], ' ');       
                                       if mas2[i] > 10 * K Then         
                                            mas2[i] := mas2[i] + K;      
                                end;    
                       end;       
                  for i := 0 to 9 do     
                         if (j = 0) then 
                               write(mas1[i]) 
                        else 
                                write(mas2[i]);    
               writeln();  
           end;  
readln();
end.

))

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

100 . напишите программу на паскале седьмое обратный корень эта настолько проста, что авторы даже поленились сочинить для нее условие! формат входных данных входной поток содержит набор целых чисел ai (0 ≤ ai ≤ 1018), отделённых друг от друга произвольным количеством пробелов и переводов строк. размер входного потока не превышает 256 кб. формат результата для каждого числа ai, начиная с последнего и заканчивая первым, в отдельной строке вывести его квадратный корень не менее чем с четырьмя знаками после десятичной точки. примеры входные данные 1427 0 876652098643267843 5276538 результат работы 2297.0716 936297014.1164 0. 37.7757
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

lyukiss
evamining
Хромов1501
ann328389
vik-2202
Anna Artem
Aleksei
mausgaly
mikchaylovaalex
juliavovo
Эдгеева219
d43irina
versalmoda2971
Vladimirovich1898
Хохлова Иванович