2 рубля
Объяснение:
ограничениях: в наличии имеется 4 тыс. кг реагента А и 4 тыс. кг реагента В; общее время работы оборудования составляет 3 тыс. часов; на 1 кг краски 1го вида расходуется 0,1 кг реагента А, 0,3 кг реагента В и 0,2 час. работы оборудования; на 1 кг краски второго вида расходуется 0,2 кг7 реагента А, 0,1 кг реагента В, 0,3 час. работы оборудования; чистая прибыль от продажи 1 кг краски первого вид составляет 3 рубля, чистая прибыль от продажи 1 кг краски второго вида составляет 2 рубля.
#include <iostream>
#include <vector>
using namespace std;
int main()
{
int n, m;
cin >> n >> m;
vector<vector<int> > t(m, vector<int> (n));
for (int i = 0; i < m; ++i){
for (int j = 0; j < n; ++j){
t[i][j] = i * n + j;
}
}
for (int i = 0; i < n; ++i){
for (int j = 0; j < m; ++j){
cout << t[j][i] << " ";
}
cout << endl;
}
return 0;
}
Объяснение:
просто нужно заполнить массив . _.
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу на языке с++(со всеми объяснениями )1. написать функцию, которая принимает в качестве аргументов целочисленный массив и переменную. находит сумму четных и сумму нечетных элементов. в переменную-аргумент сохраняет максимальную из сумм. возвращает минимальную из сумм.
int r = minmax(a, b);
cout << "Сумма min " << r << ", сумма max " << b << endl;
return 0;
}
По поводу "всех объяснений" - я этого не понимаю. Написать что делает каждый оператор, зачем он тут и почему именно такой - это долгое и бессмысленное занятие, ответ будет объемом в несколько книжных страниц, но все равно толком ничего не даст. Если Вы не умеет программировать - учится надо не по ответу на задачу, а если умеете - никакое описание не нужно.
Единственная заморочка тут - передача длины массива в вызываемую функцию. В С++ с этим беда, потому обычно используют библиотечный класс Vector, где можно узнать длину массива. Вместо массива в С++ при вызове функции передается указатель на его первый элемент, поэтому информацию о длине массива получить нельзя. Так что нужно передавать еще один параметр - длину массива. Но в задании сказано, что параметра всего два и второй служит для получения максимальной из двух сумм. Но это при возвращении результата! Поэтому было принято решение при вызове функции в качестве b передать длину массива.