Dmitrii836
?>

Программа в c или c++ составить программу в котором содержится информация о группе с n количеством студентов 1. реализовать поиск студентов по возрасту. 2.с функции сделать замену записи самый маленький с самым большим возрастом.

Информатика

Ответы

Yevgenevich

На PascalABC.NET можно так:

var k: array of string;

procedure CreatOrAdd(add: boolean);

begin

 var i,n: integer;

 write('введите кол-во учеников: ');

 readln(n);

 if (add) then  

   begin

     setlength(k,k.Length+n);

     for i:= 0 to n-1 do  

       begin

       write('введите ФИО:');

       readln(k[k.Length-n+i]);

       end;

   end

 else  

   begin

   setlength(k,n);

   for i:= 0 to n-1 do  

     begin

     write('введите ФИО:');

     readln(k[i]);

     end;

   end;

end;

procedure out;

begin

 try

   writeln('Список класса:');

   for var i:= 0 to k.Length-1 do writeln(k[i]);

 except

   on e: System.Exception do writeln(e.Message);  

 end;

end;

procedure menu;

begin

writeln('1, Создание списка класса');

writeln('2, Добавление');

writeln('3, Удаление');

writeln('4, Вывод списка класса');

writeln('5, EXIT');

end;

procedure delet;

begin

 var n: integer;

 write('введите номер удаляемого ученика: ');

 readln(n);

  try

   if (n<=k.Length) then

   k := k.Where(t -> t<>k[n-1]).ToArray()

   else writeln('Ошибка');

 except

   on e: System.Exception do writeln(e.Message);  

 end;

end;

var

kom: byte;

begin

repeat

menu;

readln(kom);

case kom of

1: creatoradd(false);

2: creatoradd(true);

3: delet;

4: out;

5: exit;

end;

until kom = 5;

end.

Если будут вопросы, спрашивайте.

vera4
Вот задача для "троечников" с дополнительной оценкой:

program pr1;
uses
crt;

const
arr1 : array[1..12] of integer = (5, 4, -3, 1, 0, -4, 0, 25, -8, 0, -17, -1);

type
arr2 = array of integer;

var
arr : arr2;
n : integer;
i, sot, spl, snu : byte;
ch : char;

begin
write('Хотите использовать заданный по умолчанию массив? (y/n): ');
ch := readkey;
writeln(ch);
sot := 0;
spl := 0;
snu := 0;
if ((ch='y') or (ch='Y')) then begin
{ Используем заданный по умолчанию }
for i:=1 to 12 do begin
if arr1[i] > 0 then inc(spl);
if arr1[i] < 0 then inc(sot);
if arr1[i] = 0 then inc(snu);
write(arr1[i], ' ');
end;
writeln;
end
else begin
{ Создаём и заполняем новый массив }
write('Введите желаемый размер массива: ');
readln(n);
setLength(arr, n);
writeln('Введите элементы массива:');
for i:=0 to high(arr) do
readln(arr[i]);
for i:=0 to high(arr) do begin
if arr[i]>0 then inc(spl);
if arr[i]<0 then inc(sot);
if arr[i]=0 then inc(snu);
write(arr[i], ' ');
end;
writeln;
end;

writeln('Количество отрицательных элементов: ', sot);
writeln('Количество нулевых элементов: ', snu);
writeln('Количество положительных элементов: ', spl);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Программа в c или c++ составить программу в котором содержится информация о группе с n количеством студентов 1. реализовать поиск студентов по возрасту. 2.с функции сделать замену записи самый маленький с самым большим возрастом.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Viktor1316
starabanov
Vera_Shuklin
krylova-natali
eremenkou
s-laplandia6
Лилин1079
ikuvila5484
vallod
Adno1578
Dimston134877
tolyan791
mouse-0211fsb3509
Хабарьева Андрей1056
avdeevau807