myglassi26
?>

Писать со сдвигом напишите программу которая получает на вход одну фразу и печатает ее как в примере ниже. sample input: sample output: т ет вет ивет ривет питон !

Информатика

Ответы

mail5

fraze = str(input())

for i in range(len(fraze)):

   print(fraze[i:])

ЮлияНиколаевна1748

program raf105;

var

 s: string;

 i1,i2,i3,i4,i5,o,x: integer;

 domok_komod: boolean;

begin

s:= '';

for  i1:=1 to 4 do

 for  i2:=1 to 4 do

   for  i3:=1 to 4 do

     for  i4:=1 to 4 do

       for  i5:=1 to 4 do

       begin

         case i1 of

           1: s[1]:= 'Д';

           2: s[1]:= 'К';

           3: s[1]:= 'М';

           4: s[1]:= 'О';

         end;

         case i2 of

           1: s[2]:= 'Д';

           2: s[2]:= 'К';

           3: s[2]:= 'М';

           4: s[2]:= 'О';

         end;

         case i3 of

           1: s[3]:= 'Д';

           2: s[3]:= 'К';

           3: s[3]:= 'М';

           4: s[3]:= 'О';

         end;

         case i4 of

           1: s[4]:= 'Д';

           2: s[4]:= 'К';

           3: s[4]:= 'М';

           4: s[4]:= 'О';

         end;

         case i5 of

           1: s[5]:= 'Д';

           2: s[5]:= 'К';

           3: s[5]:= 'М';

           4: s[5]:= 'О';

         end;

         if s = 'ДОМОК'

           then domok_komod:= true;

         if s = 'КОМОК' //Это не опечатка. Так и должно быть

           then domok_komod:= false;

         if domok_komod

           then o+= 1;

         x+=1;

       end;

writeln('Слов между ДОМОК и КОМОД (включительно): ',o);

writeln('Всего возможных комбинаций: ',x);

end.

Язык PascalABC
Korinchan390

program raf105;

var

 s,s1,s2: string;

 slov,numb,i,j,l: integer;

begin

writeln('Введите строку:');

readln(s);

s:= lowercase(s);

s1:= '';

s2:= '1234567890';

while j<>-1 do

begin

 j+= 1;

 l+= 1;

 for i:=1 to length(s1) do

   if (s[j] = s1[i]) and (slov = 0)

     then slov+= 1

     else if (i<=length(s2)) and (s[j] = s2[i])

     then numb+=1;

 if s[j+1] = ' '

   then j:= -1;

end;

for i:=l+1 to length(s) do

begin

 if s[i] = ' '

   then

   begin

     for j:=1 to length(s1) do

       if s[i+1] = s1[j]

         then slov+= 1;

   end

   else

   begin

     for j:=1 to length(s2) do

       if s[i] = s2[j]

         then numb+=1;

   end;;

end;

writeln;

writeln('В строке:');

writeln(slov,' сл.');

writeln(numb,' циф.');

end.

Язык PascalABC

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Писать со сдвигом напишите программу которая получает на вход одну фразу и печатает ее как в примере ниже. sample input: sample output: т ет вет ивет ривет питон !
Ваше имя (никнейм)*
Email*
Комментарий*
▲