VadimovichSvetlana622
?>

Вводится строка из двух слов, разделённых между собой пробелом. составьте программу, позволяющую вставить слово t после первого слово строки s. строку s и слово t ввести с клавиатуры. вот пример:

Информатика

Ответы

nasrelza1012

PascalABC.NET

begin

 var s := ReadlnString;

 var t := ReadlnString;

 Insert(t + ' ', s, Pos(' ', s) + 1);

 s.Println

end.

lzelenyi5
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
const
  m = 10;

var
  t: array[1..m] of integer;
  i, n, nm, sm: integer;

begin
  //Заполняем массив сл.числами и подсчитываем
  //количество элементов и среднее арифметическое
  //согласно условию задачи
  for i := 1 to m do
  begin
    t[i] := random(-20, 20);write(t[i]:4);
    if (i > 1) and (i <= m) then
      if t[i] > t[i - 1] then n := n + 1
      else if t[i] < t[i - 1] then begin
        sm := sm + t[i];nm := nm + 1;
      end;
  end;
  writeln;
  writeln('число элементов больших предыдущего = ', n);
  writeln('ср. арифметическое элементов меньших предыдущего = ', sm / nm);  
 
end.

Тестовое решение:
    6  13  19   8 -19 -11 -20 -15 -19 -13
число элементов, больших предыдущего = 5
среднее арифметическое элементов, меньших предыдущего = -12.5
informalla
//я писал этот унылый код полтора часа. Полтора часа, Карл! Я слишком расслабился.
#include <iostream>
using namespace std;
int k=2;

bool StrangeSeq(int n){
     if (k<n){
              if(n%k==0){
                         cout<<"false";
                         return false;
                         }
                         k++;
                         StrangeSeq(n);
                         }
                         else
                         {
                             cout<<"true";
                             return true;
                             }
}
                
int main(){
    int n;
    cin>>n;
    StrangeSeq(n);
    cin.get();
    cin.get();
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вводится строка из двух слов, разделённых между собой пробелом. составьте программу, позволяющую вставить слово t после первого слово строки s. строку s и слово t ввести с клавиатуры. вот пример:
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Суханова1532
grenysherg2873
diana0720
svetlanadianowa
Кожуховский398
olgaprevisokova302
koptevan6
rimmaskis
Mikhailovich_Viktoriya
annasolod
missmorozova2
tolyan791
Sergei
sabinina0578
marinakmaa86
▲