sse1105
?>

Составить программу на паскале, которая будет вычислять значение выражения(оно находится во вложении), используя процедуру, вычисляющую n степень.

Информатика

Ответы

Bezzubova_Stepanov1355
Var
  n, k, t, i, counter, j: int64;
  c: array[1..10]of int64;
  a: array[1..100000]of int64;
  ar: array[1..10, 1..100000]of int64;
  count: array[1..10]of int64;
  b: boolean;

 label l1;

  begin
  b := true;
  counter := 0;
  read(n, k, t);
  for i := 1 to n do read(c[i]);
  for i := 1 to k do read(a[i]);
  l1:
  while (counter <> k) do
   begin
    for j := 1 to n do
     begin
      for i := 1 to c[j] do
       begin
        if(ar[j, i] <= a[counter + 1]) then
         begin
          ar[j, i] := t + a[counter + 1];
           counter := counter + 1;
          count[j] := count[j] + 1;
          b := false;
          goto l1;
        end;
      end;
    end;
    if(b = true) then counter := counter + 1;
    b := true;
  end;
  for i := 1 to n do write(count[i], ' ');
end.
cherkashenko87543
Достоинство числовой - она сохранить числовые значения будь цены, счета, цифры, пароли. недостатки - не может хранить текст
Графическая - достоинства: Может хранить изображения, используемые как доказательства, но не может передавать звук.
Звуковая - передает звуки, музыку, голос. Недостаток не может передать изображение
Видео - может передавать кадры и изображения соединные в последовательность, но не может передавать звук.
Но если рационально и правильно соединить несколько типов информации, то мы сможем передать любые данные.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу на паскале, которая будет вычислять значение выражения(оно находится во вложении), используя процедуру, вычисляющую n степень.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

betepah
ASRodichev
gumirovane2294
uvarovig
Stepanovich_Makarov
sohrokova809
Sergei1805
lider-mpl550
Александр Сергей
Сергеевич1386
antoska391
puchkovajulia
lor005148
Blekjek730
verkop9