Для початку давайте розберемося в тому, що саме являє собою форматування диска, і чому після нього є реальна можливість відновити якщо не всі, то більшу частину даних. При первинному (або нізькорівневому ) форматуванні відбувається створення файлової таблиці, в яку система записує всі дані, необхідні для роботи. Коли запускається процес форматування диска, таблиця нікуди не дівається, а лише обнуляється. Стара інформація, яка перебувала в ній, не може відповідати розмірам таблиці, тому стає просто невидимою для системи. І якщо на диск не проводився запис нових даних, тоді відновити файли після форматування диска можна.
Слід враховувати і те, тип якого форматування ви використовували. Якщо було вибрано швидке форматування, тоді відбувається тільки очищення заголовків файлової системи, а от інформація з жорсткого диска нікуди не видаляється. На щастя, в більшості випадків використовують саме швидке форматування.
При повному форматуванні в кожному секторі жорсткого диска видаляється вся інформація, тому відновлення даних в такому випадку являє собою практично неможливу задачу.
Незважаючи на всі проблеми після форматування диска дані можна відновити. Справа в тому, що пошук даних після форматування по своєму процесу нічим не відрізняється від відновлення даних після їх видалення з комп'ютера. Правда, в силу того що потрібно відновлювати цілий диск, то операція ця займає чимало часу.
Для відновлення даних після форматування дуже важливо не записувати зверху ніяку інформацію. Створення нових папок і установка системи зводить ваші шанси на відновлення втраченої інформації до мінімуму. Зауважте, що після форматування операційні системи XP і Vista самі створюють деякі папки. Також після форматування диска, якщо є можливість, не перезавантажуєте комп'ютер, а просто вимкніть його.
Щоб відновити дані з диска, знадобиться інший комп'ютер, на який попередньо встановлюють спеціальну програму. Потім до комп'ютера підключають диск, який потрібно відновити, і запускають сканер. Після закінчення сканування диска, вам буде зрозуміло, що саме вдасться відновити, а що - ні.
Зверніть увагу на те, що для відновлення даних вам знадобиться комп'ютер, у якого обсяг диска перевищує ваш.
Ми розібралися з тим, як відновити файли після форматування, тепер же поговоримо про те, які програми можна використовувати для цього. Є маса безкоштовних і ліцензійних утиліт, які до вам впоратися з цим завданням. Таке зійде ???
Поделитесь своими знаниями, ответьте на вопрос:
1)выяснить, есть ли в массиве строки, в которых буква а расположена справа отбуквы д (известно, что буква д в каждой строке единственная2) дан динамический массив целых чисел {ai} (i=1, 2, ), целое число k(k > 0). осуществить циклический сдвиг значений компонентов массива вправо на 1 компонент. для обращение к элементам массива использоватьуказатель3) имеется множество, содержащее натуральные числа из диапазона [-99..99]. сформировать два множества, первое из которых содержит все числа изданного множества, которые делятся на 3 и 5, а второе — все составные. 4) дано слово. поменять местами его вторую и предпоследнюю буквы.5) дано множество m, содержащее цветов {крокус: март-апрель, нарцисс: апрель-май, лилия: июнь-июль, тюльпаны: апрель-май, гладиолус: августсентябрь} . написать программу, которая позволит пользователю вводит названиецветка и видеть период цветения.6) дан массив целых чисел a. найти суммы положительных и отрицательныхэлементов массива, используя функцию определения суммы.p.s. программы должны быть на delphi!
"Памяти наших дедов посвящается..."
const
n=10;
var
a:array[1..n,1..n] of integer;
i,j,SumDiag,k:integer;
p:real;
begin
Writeln('*** Исходная матрица ***');
Randomize;
SumDiag:=0;
for i:=1 to n do begin
for j:=1 to n do begin
a[i,j]:=Random(199)-99;
if i=j then SumDiag:=SumDiag+a[i,j];
Write(a[i,j]:4)
end;
Writeln
end;
for i:=1 to 4*n do Write('-');
Writeln;
Writeln('Сумма элементов на главной диагонали ',SumDiag);
p:=SumDiag/15;
k:=0;
for i:=1 to n do
for j:=1 to n do
if a[i,j]<p then k:=k+1;
Writeln('Искомое количество элементов ',k)
end.
Пример
*** Исходная матрица ***
95 37 30 21 83 -99 48 -40 49 -19
-66 -82 88 -24 70 14 -88 11 60 14
-72 -80 90 25 68 23 91 66 -54 52
33 16 25 -72 85 58 -39 44 8 -29
8 78 -79 51 50 -61 -13 -87 87 66
63 -45 94 -48 59 76 46 -94 53 -40
-90 81 -85 96 47 18 -8 61 -10 -87
-47 -33 -97 -10 -93 -51 98 -60 74 30
-63 78 79 -21 89 -21 21 -26 -31 -91
-88 -45 91 -51 -39 26 64 -75 -96 -67
Сумма элементов на главной диагонали -9
Искомое количество элементов 46