vasilyevjob6
?>

Нарисуйте на клетчатом поле первую букву своего имени (р) с закрашенных клеток составьте программу рисования этой буквы исполнителем робот исходное положение робота обозначена квадратом в центре поля​

Информатика

Ответы

kuzinnv1968
program ggl;
Это название программы
var  n, i, sum : integer; 
Описание переменных
a : array [1..1000] of integer;
Описание массива а (он целочиленный, в интервале от 1 до 1000)
begin  readln (n);
Начало программы, запрос значение переменной n
 sum := 0;
Присвоение переменной sum значение 0
begin  readln (n);
  sum := 0;
  for i := 1 to n do  begin  
  a[i] := random (100);    
write (a[i], ' ');   
 sum := sum + a[i];  
end;  
begin характеризует начало новой подпрограммы. Она - цикл, в котором идет перебор чисел от 1 до значения n, элементам массива a присваиваются рандомные числа от 1 до 100, элементы массива выводятся на экран.
После идет подсчет значения переменной sum (причем сначала находится, например, первый элемент массива, а уже после значение переменной sum, после второй элемент массива и он прибавляется к прежнему значению переменной sum). Подпрограмма кончается.
writeln;  
write (sum / n);
end.
Вывод значения деления переменной sum на переменную n. Конец всей программы.
asvavdeeva
Уберите char. После begin не ставится точка с запятой. В Else не нужна точка с запятой, если там один оператор. После of точка с запятой не ставится. В перечне значений case не нужно =. Вывод по ходу программы не очень удобный. В последнем выводе выводите переменные просто как буквы, это ошибка. Вот, исправил основные ошибки. program abc; var a,b:integer; begin writeln('Введите количество десятков лет'); readln(a); case a of 1:write('десять'); 2:write('двадцать'); 3:write('тридцать'); 4:write('сорок'); 5:write('пятьдесят'); 6:write('шестьдесят'); 7:write('семьдесят'); 8:write('восемьдесят'); 9:write('девяносто'); Else Write('Число введено неверно') end; writeln('Введите количество едениц лет'); readln(b); case b of 1:write('один'); 2:write('два'); 3:write('три'); 4:write('четыре'); 5:write('пять'); 6:write('шесть'); 7:write('семь'); 8:write('восемь'); 9:write('девять'); Else write('Число введено') end; write(a, b, ' лет'); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нарисуйте на клетчатом поле первую букву своего имени (р) с закрашенных клеток составьте программу рисования этой буквы исполнителем робот исходное положение робота обозначена квадратом в центре поля​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

nastya3213868
irina-mic
Cannabikh
inaine73
ismailovi670771
klepa-79
Шиловский126
Lapushkina
Angelina1139
Rustamov741
anikamalish
Lerkinm
sve707ta
frame45