Zhilinoe134
?>

Кумир составьте программу, которая находит и записывает в файл все делители целого числа, введенного с экрана.

Информатика

Ответы

BelozerovaGeller648
Const
  n = 11;

var
  x: array[1..n] of integer;
  i, k, d, s: integer;

begin
  Randomize;
  Writeln('Элементы массива');
  k := 0; s := 0;
  for i := 1 to n do
  begin
    d := Random(11) - 5;
    Write(d:3);
    if (i mod 2) = 0 then begin { четное место }
      if d = 1 then Inc(k);
      x[i] := d
    end
    else begin
      if d < 0 then s := s + d;
      x[i] := sqr(d)
    end
  end;
  Writeln;
  Writeln('Результирующий массив');
  for i := 1 to n do Write(x[i]:3);
  Writeln;
  Writeln('Количество единиц на четных местах равно ', k);
  Writeln('Сумма отрицательных элементов на нечетных местах равна ', s)
end.

Тестовое решение:
Элементы массива
 -3  0 -5  1  5  1 -3 -4  5 -3 -2
Результирующий массив
  9  0 25  1 25  1  9 -4 25 -3  4
Количество единиц на четных местах равно 2
Сумма отрицательных элементов на нечетных местах равна -13
rinata542
Sub Zadanie16087714()
    Const text = "Вскоре после маленькой княгини вошел массивный, толстый молодой человек с стриженою головой, в очках, светлых панталонах по тогдашней моде, с высоким жабо и в коричневом фраке. Этот толстый молодой человек был незаконный сын знаменитого екатерининского вельможи, графа Безухова, умиравшего теперь в Москве. Он нигде не служил еще, только что приехал из-за границы, где он воспитывался, и был первый раз в обществе. Анна Павловна приветствовала его поклоном, относящимся к людям самой низшей иерархии в ее салоне. Но, несмотря на это низшее по своему сорту приветствие, при виде вошедшего Пьера в лице Анны Павловны изобразилось беспокойство и страх, подобный тому, который выражается при виде чего-нибудь слишком огромного и несвойственного месту. Хотя действительно Пьер был несколько больше других мужчин в комнате, но этот страх мог относиться только к тому умному и вместе робкому, наблюдательному и естественному взгляду, отличавшему его от всех в этой гостиной. "
    k = 0

    for i = 1 to Len(text)
        c = LCase(Mid(text, i, 1))
        If c="а" or c="е" or c="о" or c="у" or c="и" or c="я" or c="ё" or c="ю" or c="э" or c="ы" Then
            k = k + 1
        End If
    next
    MsgBox (k)
End Sub

Call Zadanie16087714()

ответ 323. Правильно?
Код написан на VBScript

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Кумир составьте программу, которая находит и записывает в файл все делители целого числа, введенного с экрана.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mlubov1
ivanjeka87
Maksimova1320
Shurshilina850
tata-novik
Zakharov Lilit
dmitriyb1
prokodasha
Nzharenikova
Grigorevna23
inbox466
Svetlana191
olimov
andr77716
Richbro7