PivovarovaIlina1437
?>

Доброго вечера, . решите, , по информатике.представленный ниже фрагмент программы обрабатывает элементы одномерного целочисленного массива a с индексами от 1 до 10. перед началом выполнения данного фрагмента эти элементы массива имели значения 2, 3, 5, 3, 10, 7, 4, 6, 12, 9 (т. е. a [1] = 2, a [2] = 3, …, a [10] = 9определите значение переменной s после выполнения фрагмента, записанного ниже на пяти языках программирования.n : = 10; s : = 0; for i: =2 to n do beginif a[i-1] < a[i] then begina[i] : = a[i] - a[i-1]; s : = s + a[i]endend; ​

Информатика

Ответы

luksorsps20096124

ответ:

program gt;

var b: array[1..40]of integer;

i: integer;

begin

randomize;

for i: =1 to 40 do

begin

b[i]: =random(100);

if(i< =10)then b[i]: =b[i]*3;

write(b[i],' ');

end;

end.

2)

задается с клавиатуры

program gt;

var b: array[1..40]of integer;

i: integer;

begin

for i: =1 to 40 do

begin

read(b[i]);

if(i< =10)then b[i]: =b[i]*3;

end;

for i: =1 to 40 do

write(b[i],' ');

end.

darialyagina

type

firma = record

 fam:string;

 adres:string;

 end;

var

mas:array[1..8] of firma;

i,k:integer;

str:string;

begin

 mas[1].fam:='Кузин';

 mas[2].fam:='Куравлев';

 mas[3].fam:='Кудин';

 mas[4].fam:='Кульков';

 mas[5].fam:='Кубиков';

 mas[6].fam:='Иванов';

 mas[7].fam:='Петров';

 mas[8].fam:='Сидоров';

 mas[1].adres:='ул.Мира,7';

 mas[2].adres:='ул.Маркса,6';

 mas[3].adres:='ул.Комсомольская,17';

 mas[4].adres:='ул.Ленина,5';

 mas[5].adres:='ул.Центральная,18';

 mas[6].adres:='ул.Клубная,26';

 mas[7].adres:='ул.Чехова,2';

 mas[8].adres:='ул.Амосова,68';

 write('Введите фамилию сотрудника ->  ');readln(str);

 k:=0;

 for i:=1 to 8 do

 begin

   if str=mas[i].fam then

   begin

     k:=k+1;

     writeln('фамилия - ',mas[i].fam);

     writeln('адрес   - ',mas[i].adres);

   end;

 end;

 if k=0 then writeln('такого сотрудника нет!');

 readln;

end.

Объяснение:

Это ответ на задание 2

Qiwi +79172489972

Vip2002www86

Написал на том, что было под рукой: 1C

Если Квартира > ЭтажейВДоме * КвартирНаЭтаже Тогда  

 Сообщить("Нет такой квартиры в доме, мало этажей!");

ИначеЕсли Квартира <= КвартирНаЭтаже Тогда  

 Сообщить("Живет на первом этаже");

Иначе

 ЖиветНа = Цел(Квартира / КвартирНаЭтаже);

 ОстатокЭт = Квартира%КвартирНаЭтаже;

 Если ОстатокЭт>0 Тогда  //

  ЖиветНа = ЖиветНа+1;

 КонецЕсли;

 Если ЖиветНа%2=0 И ЖиветНа=ЭтажейВДоме Тогда // это четный и последний

  ВыходитьНа = ЖиветНа-1;

 ИначеЕсли ЖиветНа%2=0 Тогда // четный в НЕчетный этаж

  ВыходитьНа = ЖиветНа+1;

 Иначе

  ВыходитьНа = ЖиветНа;

 КонецЕсли;

 Сообщить(" Выйдет на: "+ВыходитьНа);

КонецЕсли;

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Доброго вечера, . решите, , по информатике.представленный ниже фрагмент программы обрабатывает элементы одномерного целочисленного массива a с индексами от 1 до 10. перед началом выполнения данного фрагмента эти элементы массива имели значения 2, 3, 5, 3, 10, 7, 4, 6, 12, 9 (т. е. a [1] = 2, a [2] = 3, …, a [10] = 9определите значение переменной s после выполнения фрагмента, записанного ниже на пяти языках программирования.n : = 10; s : = 0; for i: =2 to n do beginif a[i-1] < a[i] then begina[i] : = a[i] - a[i-1]; s : = s + a[i]endend; ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

benonika
kostavaani
helenya
andrey4work918
gav973
alf206
dentalfamily
delfa-r6289
staskamolbio5152
atamanov5
Григорьевич915
mrvasilev2012
Nikolaevich-Svetlana388
Timurr007
Vello Olga