Алина Ракитин1730
?>

Напишите программу, позволяющую определить, входит ли заданная цифра в некоторое целое неотрицательное число

Информатика

Ответы

olofinskayae

var

n, r: integer;

begin

write('n = ');

readln(n);

writeln;

while (n > 0) and (r < > 2) do

begin

r : = n mod 10; { < == последняя цифра числа }

n : = n div 10 { < == удаляем последнюю цифру }

end;

writeln(r = 2); { < -- выводим значение выражения (r=2) }

readln

end.

Wlad967857

КРАТКИЙ КОНСПЕКТ-

Воспроизводимость информации тесно связана с ее передаваемостью и не является ее независимым базовым свойством. Если передаваемость означает, что не следует считать существенными отношения между частями системы, между которыми передается информация, то воспроизводимость характеризует неиссякаемость и неистощимость информации, т.е. что при копировании информация остается тождественной самой себе. 

  Фундаментальное свойство информации - преобразуемость. Оно означает, что информация может менять и форму своего существования. Копируемость есть разновидность преобразования информации, при котором ее количество не меняется. В общем случае количество информации в процессах преобразования меняется, но возрастать не может. Свойство стираемости информации также не является независимым. Оно связано с таким преобразованием информации (передачей), при котором ее количество уменьшается и становится равным нулю.

СДЕЛАЙ ЛУЧШИМ

elvini857

Информацию следует считать особым видом ресурса, при этом имеется ввиду толкование "ресурса" как запаса неких знаний материальных предметов или энергетических, структурных или каких-либо других характеристик предмета. В отличие от ресурсов, связанных с материальными предметами, информационные ресурсы являются неистощимыми и предполагают существенно иные методы воспроизведения и обновления, чем материальные ресурсы. Рассмотрим некоторый набор свойств информации:

1) запоминаемость; 

2) передаваемость; 

3) преобразуемость; 

4) воспроизводимость; 

5) стираемость. 

   Свойство запоминаемости - одно из самых важных. Запоминаемую информацию будем называть макроскопической (имея ввиду масштабы запоминающей ячейки и время запоминания). Именно с макроскопической информацией мы имеем дело в реальной практике. 

   Передаваемость информации с каналов связи (в том числе с помехами) хорошо исследована в рамках теории информации К.Шеннона. В данном случае имеется ввиду несколько иной аспект информации к копированию, т.е. к тому, что она может быть "запомнена" другой макроскопической системой и при этом останется тождественной самой себе. Очевидно, что количество информации не должно возрастать при копировании. 

   Воспроизводимость информации тесно связана с ее передаваемостью и не является ее независимым базовым свойством. Если передаваемость означает, что не следует считать существенными отношения между частями системы, между которыми передается информация, то воспроизводимость характеризует неиссякаемость и неистощимость информации, т.е. что при копировании информация остается тождественной самой себе. 

   Фундаментальное свойство информации - преобразуемость. Оно означает, что информация может менять и форму своего существования. Копируемость есть разновидность преобразования информации, при котором ее количество не меняется. В общем случае количество информации в процессах преобразования меняется, но возрастать не может. Свойство стираемости информации также не является независимым. Оно связано с таким преобразованием информации (передачей), при котором ее количество уменьшается и становится равным нулю.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, позволяющую определить, входит ли заданная цифра в некоторое целое неотрицательное число
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Михайлович1309
polotovsky
Yurevich1344
nastikak8
mgrunova3966
Александрович_Викторовна
manimen345
Валуева
NikolayGoncharov
polotovsky
Sergei_sergei
departed744
izumrud153
baranovaas
qcrv15312
▲