vadim330
?>

реализуйте алгоритм бинарного поиска. входные данные в первой строке входных данных содержатся натуральные числа n и k (0nk1 во второй строке n элементов первого массива, отсортированного по возрастанию, а в третьей строке – k элементов второго массива. элементы обоих массивов - целые числа, каждое из которых по модулю не превосходит 109 выходные данные требуется для каждого из k чисел вывести в отдельную строку "yes", если это число встречается в первом массиве, и "no" в противном случае. примеры входные данные 10 5 1 2 3 4 5 6 7 8 9 10 -2 0 4 9 12 выходные данные no no yes yes no

Информатика

Ответы

msk27

arr1 = []

n, k = map(int, input().split())

for i in range(n):

  inp = int(input())

  arr1.append(inp1)

for y in range(k):

  if y in arr1:

     print("YES")

  else:

     print("NO")

Объяснение:

Astrians

1) 5 9 13 17 21 25 29 33 37 41 45 49

 

var sum, i, s: integer;  //обыявляем необходимые переменные

//sum - сумма, i - кол-во слогаемых, s - само слогаемое

begin  //начало
  sum := 0; i := 1; s := 5;  //первое слогаемое = 5
  repeat
    sum := sum + s;  //к сумме прибавляем слагаемое
    s := s + 4;  //увеличиваем слогаемое
    i := i + 1;   //увеличиваем кол-во слогаемых
  until (sum = 324);  //выход когда сумма равна 324
  writeln ('Слогаемых: ');  // выводим кол-во слогаемых
  write (i);
end.  //конец

 

shuttse
Вариант 11 Дядя Федор, кот Матроскин и пес Шарик летом жили в Простоквашино, а папа с мамой слали им письма, посылки, телеграммы и бандероли, которые доставлял почтальон Печкин. Каждое письмо весило в среднем 100 г, каждая посылка - 5 кг, каждая телеграмма - 50 г, каждая бандероль - 500 г. Дядя Федор получил 10 писем, 2 посылки, 10 телеграмм и 1 бандероль. Кот Матроскин получил 4 письма, 1 посылку, 2 телеграммы и 1 бандероль. Пес Шарик не получил ни одного письма, ни одной телеграммы, зато получил 4 посылки и 2 бандероли.Построить электронную таблицу, из которой будет видно: сколько и какой почты получил каждый из трех жителей Про-стоквашино; сколько килограммов почты получил каждый из трех простоквашинпев; сколько весила вся доставленная Печкиным почта одного вида; какой общий груз пришлось перенести почтальону Печкину.  смотри хls
Решить одну из , и сделать таблицу по информатике вариант 11 дядя федор, кот матроскин и пес шарик л

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

реализуйте алгоритм бинарного поиска. входные данные в первой строке входных данных содержатся натуральные числа n и k (0nk1 во второй строке n элементов первого массива, отсортированного по возрастанию, а в третьей строке – k элементов второго массива. элементы обоих массивов - целые числа, каждое из которых по модулю не превосходит 109 выходные данные требуется для каждого из k чисел вывести в отдельную строку "yes", если это число встречается в первом массиве, и "no" в противном случае. примеры входные данные 10 5 1 2 3 4 5 6 7 8 9 10 -2 0 4 9 12 выходные данные no no yes yes no
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mmoskow3
alexst123012225
Solovetzmila
Воздвиженская
museumuzl
Андрееевич787
zhannasokortova
Алексей424
Скворцов
bykotatyana
afomin63
esnails17
info2990
zrs-546
baron