avetisov-84850
?>

Дано натуральное n. вычислить: у - 1 • 3 • 5 х х (2n - 1 составить программу в 2-х циклах (постусловие, предусловие). pascal.

Информатика

Ответы

Олегович Паутова
1. Программа, создающая тестовый файл.

// PascalABC.NET 3.1, сборка 1213 от 04.04.2016
begin
  var f: file of integer;
  var t:integer;
  Assign(f,'input.dat'); Rewrite(f);
  for var j:=1 to 5 do begin
    for var i:=1 to 10 do begin t:=Random(10,99); Write(f,t) end;
    for var i:=1 to 10 do begin t:=-Random(10,99); Write(f,t) end
    end;
  f.Close;
end.

2. Программа, которую требовалось написать

// PascalABC.NET 3.1, сборка 1213 от 04.04.2016
begin
  var f,g: file of integer;
  var a:=new integer[20];
  var t:integer;
  Assign(f,'input.dat'); Reset(f);
  Assign(g,'output.dat'); Rewrite(g);
  while not f.Eof do begin
    for var i:=0 to 19 do Read(f,a[i]);
    a:=a[10:15]+a[0:5]+a[15:20]+a[5:10];
    for var i:=0 to 19 do Write(g,a[i])
    end;
  f.Close;
  g.Seek(0);
  while not g.Eof do begin Read(g,t); Print(t) end;
  g.Close
end.
Наталья_Владимир708
Using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
using System.IO;

namespace СиШарп
{
    class Program
    {
        static void Main(string[] args)
        {
            int[] A = File.ReadAllText("D:\\f.txt").Split().Select(x=>int.Parse(x)).ToArray();
//            for(int i = 0; i < A.Length; i++)
//               Console.Write("{0} ",A[i]);
            using (StreamWriter g = File.CreateText("D:\\g.txt"))
            {
                Console.WriteLine("\n{0}", "Введите номер задания (0 - а, 1 - б)");
                int C = int.Parse(Console.ReadLine());
                C = 5 + C * 5;
                int i = 0;
                while (i < A.Length)
                {
                    for (int j = i; j < i + C; j++)
                        g.Write("{0} ",A[j]);
                    i += C*2;
                    for (int j = i; j < i + C; j++)
                        g.Write("{0} ", A[j]);
                    i -= C;
                    for (int j = i; j < i + C; j++)
                        g.Write("{0} ", A[j]);
                    i += C*2;
                    for (int j = i; j < i + C; j++)
                        g.Write("{0} ", A[j]);
                    i += C;
                }
            }
            Console.ReadKey();
        }
    }
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дано натуральное n. вычислить: у - 1 • 3 • 5 х х (2n - 1 составить программу в 2-х циклах (постусловие, предусловие). pascal.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

tefdst
baranovaas
Попов1946
kenni19868
adminaa
iamhrusha
yfetyukov
Panda062000
zatoichi69
zerckaln
tatyana58
samuilik-v
vladimirkirv
evrotrastop64
владимировнаКлютко