Равиль_Евгеньевич1808
?>

дана точка на плоскости с координатами (х, у составить программу на языке c#, которая выдает одно из сообщений "да", "нет", "на границе" в зависимости от того, лежит ли точка внутри заштрихованной области, вне заштрихованной области или на ее границе

Информатика

Ответы

svetasvetlana429
Ну, в общем, лови решение.

{ FreePascal 2.6.4}
program test;
uses
    crt;
var
    a, b, c, d  : integer;
    f : longint;

procedure swap (var x : integer; var y : integer);
var z : integer;
begin
    z := x;
    x := y;
    y := z;
end;

function nod (m, n : integer) : integer;
begin
    while m<>n do begin
        if m>n
        then
            m:=m-n
        else
            n:=n-m;
    end;
    nod := m;
end;

function max (a,b : integer) : integer;
begin
    if a>b
    then max := a
    else max := b;
end;

function min (x, y, z : integer) : integer;
var m : integer;
begin
    m := x;
    if y<m then m := y;
    if z<m then m := z;
    min := m;
end;

function mypow (a, b : integer) : integer;
var e, f : integer;
begin
    f := 1;
    for e:=1 to b do f := f*a;
    mypow := f;
end;

function fact(a : integer) : longint;
var
    i : integer;
    res : longint;
begin
    res := 1;
    for i := 1 to a do res := res*i;
    fact := res;
end;

begin
    clrscr;
    writeln('Test of function SWAP');
    write('Input A: ');
    readln(a);
    write('Input B: ');
    readln(b);
    swap(a, b);
    writeln('A=', a, ', B=', b);
    writeln;

    writeln('Test of function NOD');
    write('Input A: ');
    readln(a);
    write('Input B: ');
    readln(b);
    c := nod(a, b);
    writeln('NOD(', a, ',', b, ')=', c);
    writeln;

    writeln('Test of function MAX');
    write('Input A: ');
    readln(a);
    write('Input B: ');
    readln(b);
    c := max(a, b);
    writeln('MAX(', a, ',', b, ')=', c);
    writeln;

    writeln('Test of function MIN');
    write('Input A: ');
    readln(a);
    write('Input B: ');
    readln(b);
    write('Input C: ');
    readln(c);
    d := min(a, b, c);
    writeln('MIN(', a, ',', b, ',', c, ')=', d);
    writeln;

    writeln('Test of function POW');
    write('Input A: ');
    readln(a);
    write('Input B: ');
    readln(b);
    c := mypow(a, b);
    writeln('POW(', a, ',', b, ')=', c);
    writeln;

    writeln ('Test of function FACT (not large than 12!)');
    write('Input A: ');
    readln(a);
    f := fact(a);
    writeln(a, '!=', f);
    writeln;
    readkey;

end.
Gulyaev_Egorkina

1. Сайт содержит 5 страниц (главная, 4 страницы без темы (полагаю, это уже Ваша работа), запустится, естественно, только у Вас на компьютере.

2. На каждой странице задан фон, цвет шрифта и размер шрифта. Вы можете менять эти параметры по своему усмотрению. О том, как это сделать, разъясню в комментариях, если будет такая необходимость.

2.1 На каждой странице содержатся гиперссылки (переход на следующую страницу, на предыдущую и возврат на главную страницу) и картинки. Картинки в примере называются "1.png", "2.png" и так далее. Найдете любые картинки по выбранной Вами теме и назовете их, как указано в html-разметке.

3. На главной странице сформирован список, содержащий ссылки на 4 страницы сайта.

Решение поставленной задачи приложено в виде текстового файла, содержащего разметку для 5 html-страниц. Нужно будет создать 5 текстовых файлов с блокнота и назвать их так, как указано в решении (не забыть изменить расширение на .html)

Загрузить text/html

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

дана точка на плоскости с координатами (х, у составить программу на языке c#, которая выдает одно из сообщений "да", "нет", "на границе" в зависимости от того, лежит ли точка внутри заштрихованной области, вне заштрихованной области или на ее границе
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Fedorova_79166180822
LIN1022
Sinelnikov1650
ВитальевичЕвгеньевич346
kit036
andreyduborezz2913
snab54
igor51766771
zabava-83
lilit-yan
Igor1406
Yezhov_igor42
muravlev2702
markitandl
proporcia46