Евгения-Валерий
?>

Составьте программу, которая из слова "робототехника" получает три слова робот, ник, бот и выводит эти слова на экран в столбик.

Информатика

Ответы

linda3930
Можно вот так, например (проверено в Dev C++):

#include <iostream>
#include <cmath>
using namespace std;
int function(float *pointer1, float *pointer2)
{
float ch1, ch2;
ch1 = powf(*pointer1, 2);
ch2 = powf(*pointer2, 2);
cout<<"Квадрат первого числа равен:"<<ch1<<endl;
cout<<"Квадрат второго числа равен:"<<ch2<<endl;
return(0);
}

int main()
{
setlocale(LC_ALL, "RUS");
float a, b;
float *pointer1;
float *pointer2;
cout<<"Введите первое число:";
cin>>a;
cout<<"Введите второе число:";
cin>>b;
pointer1 = &a;
pointer2 = &b;
function(&a,&b);
system("PAUSE");
}
egoryandiana3727283
Const
  m=10;
  n=6;
var
  a:array[1..10,1..6] of integer;
  i,j:integer;
begin
  Writeln('Элементы массива');
  for i:=1 to m do
  begin
    for j:=1 to n do
    begin
      a[i,j]:=sqr(i)+sqr(j);
      Write(a[i,j]:4)
    end;
    Writeln
  end
end.

Тестовое решение:
Элементы массива
   2   5  10  17  26  37
   5   8  13  20  29  40
  10  13  18  25  34  45
  17  20  25  32  41  52
  26  29  34  41  50  61
  37  40  45  52  61  72
  50  53  58  65  74  85
  65  68  73  80  89 100
  82  85  90  97 106 117
 101 104 109 116 125 136

const
  n = 10;
var
  a: array[1..n] of integer;
  i, t: integer;

begin
  Randomize;
  Writeln('Элементы массива');
  for i := 1 to n do
  begin
    a[i] := Random(50);
    Write(a[i]:3);
  end;
  Writeln;
  t:=a[n];
  for i:=n-1 downto 1 do a[i+1]:=a[i];
  a[1]:=t;
  Writeln('Результирующий массив');
  for i := 1 to n do Write(a[i]:3);
  Writeln
end.

Тестовое решение:
Элементы массива
 13 43 26 31  1 21 12  0 33 25
Результирующий массив
 25 13 43 26 31  1 21 12  0 33

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая из слова "робототехника" получает три слова робот, ник, бот и выводит эти слова на экран в столбик.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kovalenko262
igor8809337
gon4arovanat6
Natakarpova75732
Болеславовна
aananasAnastiya1270
nord0764
dashanna04225
sergeychelyshev197618
ольга1801
kabanovae
manimen345
VSArsentev
rozhkova
Golovinskii_Sirotkina1944