Program Nonenone;
uses crt;
var
n,i:integer;
max,v:real;
yes: string;
begin
writeln('*** alphaues is thinking... ***');
writeln('*** OK ***');
max:=0;
yes:='NO';
writeln('Введите количество машин (не больше 30 - у меня мало памяти!)');
write('N = ');
readln(n);
if n>30 then
writeln('Это слишком много!')
else
begin
writeln('Вводите зарегистрированную скорость каждого автомобиля');
for i:=1 to n do
begin
write(i,'-я машинка: ');
readln (v);
if v >300 then
begin
writeln ('по-моему, твои приборы глючат - так быстро машины не ездят');
writeln ('Это число не будет учтено');
end
else
begin
if v<30 then yes:='YES';
if v>max then max:=v;
end;
end;
writeln();
writeln('Максимальная зарегистрированную скорость ',max);
writeln('Cкорость меньше 30 км/ч? ',yes);
end;
end.
Поделитесь своими знаниями, ответьте на вопрос:
Дано натуральное четырехзначное число n. верно ли, что все четыре цифры этого числа различны. написать программу для pascal через ветвление
ИСПОЛЬЗУЕТ Приём ИЗ "...\Отделы\Обмен\", Вывод ИЗ "...\Отделы\Обмен\";
ПЕР
N, сумма, сч, скор, макс: ЦЕЛ;
УКАЗ
сумма := 0;
макс := 0;
Вывод.Цепь("Введите число автомобилей: ");
N := Приём.Число();
ЕСЛИ N < 1 И N > 30 ТО Вывод.Цепь("^Ошибка.") ИНАЧЕ
Вывод.Цепь("^Введите скорости:^");
ОТ сч := 1 ДО N ВЫП
скор := Приём.Число();
ЕСЛИ N < 1 И N > 300 ТО Вывод.Цепь("^Ошибка."); СТОП(0) КОН;
УВЕЛИЧИТЬ(сумма, скор);
ЕСЛИ скор > макс ТО макс := скор КОН;
Вывод.Цепь(" ")
КОН
КОН;
Вывод.ЧВещ("^Средняя скорость: %.1f.^", сумма / N, 0, 0, 0);
ЕСЛИ макс >= 60 ТО Вывод.Цепь("YES") ИНАЧЕ Вывод.Цепь("NO") КОН
КОН Задание.