ella-rudenko
?>

Есть текст- рядок который состоит из слов, пропусков и знаков препинания и заканчивается точкой. поменять местами первое и последнее слово. составить программу на языке паскаль​

Информатика

Ответы

fab2004

ответ:

uses crt;

 

var s,sf,sl: string;

    i,l: integer;

 

begin

writeln('введите слова: ');

readln(s);

if s[1]=' ' then       //проверяем, чтобы не было пробелов в начале строки

  repeat

  delete(s,1,1);       //удаляем пробелы в начале строки, если они есть

  until s[1]< > ' ';

l: =length(s);

if s[l]=' ' then       //проверяем, чтобы не было пробелов в конце строки

  repeat

  delete(s,l,1);       //удаляем пробелы в начале строки, если они есть

  dec(l);

  until s[l]< > ' ';

i: =1;

sf: =''; sl: ='';         //изначально переменные для первого и последнего слова пусты

while s[i]< > ' ' do       //начинаем с первого символа и прекрепляем к первому слову

      begin

      sf: =sf+s[i];       //по одному символу до тех пор, пока не дойдем до пробела

      inc(i);           //увеличиваем счетчик символов на 1

      end;

i: =l;

while s[i]< > ' ' do     //начинаем с последнего символа и прекрепляем ко второму слову (спереди, то есмть по сути перед словом =))

      begin

      sl: =s[i]+sl;     //по одному символу до тех пор, пока не дойдем до пробела

      dec(i);         //уменьшаем счетчик символов на 1

      end;

writeln(sf,' ',sl);   //вывод

readln;

end.

объяснение:

adel25159
2)суждение – это форма мышления, в которой утверждается или отрицается связь между предметом и его признаком или отношение между предметами и которая обладает свойством выражать либо истину, либо ложь. Если в суждении утверждается связь, существующая в действительности, или отрицается связь, которая в действительности отсутствует, то такое суждение будет истинным. Например, “Кража – преступление.
6) Гипотезой называют высказывание или теорию (совокупность
определенных высказываний) , представляющих собой некоторое, предположение,
то есть предположительный ответ на некоторый вопрос о существовании, о причинах какого-то явления и происхождении его и т. п. Например, предположение — до полета спутника вокруг Луны — о существовании гор и кратеров на обратной стороне Луны; гипотеза А. И.
Опарина о происхождении жизни на Земле, гипотеза о происхождении Солнечной
системы и т. п.
3)Студент занимается на 5 курсе или занимается баскетболом.
Строгая дизъюнкция: союз “или” употребляется в исключающем смысле, когда происходит выбор между двумя альтернативами: либо одно, либо другое. Исключающая (строгая) дизъюнкция (x V y) истинна тогда, когда только один из ее членов является истинным, а другой - ложным Она будет ложная, если оба ее члена одновременно истинны либо ложны.
5)Предложения в других грамматических формах (собственно вопросительные, побудительные и т. д. ) непосредственно суждениями не являются, поскольку ничего не утверждают и не отрицают.
4) истинность суждения, а тем самым и теории, состоящей из множества суждений, относительна к принятым идеализациям. Все люди рыжеволосы доказать не истинность этого суждения. Вывод такой человеческая жизнь это относительная ценность это еще один пример однозначной абсолютной безусловной истины.
1) Изучение геометрии основано на аксиоматическом методе. После формулировки основных понятий и аксиом все дальнейшие результаты теории – результаты логических рассуждений, которые оформляются в виде определенного вида утверждений. Теорема – утверждение, требующее доказательства. Лемма – вс теорема, которая приводится для того, чтобы с ее доказать следующую теорему или группу теорем. Следствие-теорема, которая позволяет более полно трактовать содержание данной теоремы, аксиомы, определения. Рассмотрим, например, формулировку теоремы, данную в следствии 1.1: если на луче отложить от начальной его точки два отрезка AB и AC и если AB = AC, то точки B и C совпадут. Условием теоремы является предложение {на луче отложить от начальной его точки два отрезка AB и AC и AB = AC}. Это предложение не является в данном виде высказыванием, но содержит описание множества объектов, относительно которых делается высказывание вида AB = AC. Из описания ясно, что речь идет о множестве отрезков луча a, отложенных от начальной его точки. Поскольку один конец отрезка фиксирован, то отрезок определяется однозначно точкой луча. Обозначим как P множество точек луча, отличных от его начальной точки. Пусть B P – заданная точка. Тогда условие теоремы является предложением относительно точки множества P. Перепишем условие теоремы в виде: A (x) = {длина отрезка Ax = AB}. Очевидно, это предикат. Заключение теоремы есть предикат B (x) = {точка x совпадает с точкой B}. Тогда теорему можно переформулировать следующим образом: если x – произвольная точка луча AB такая, что Ax = AB, тогда точка x совпадает с точкой B.На основании этого утверждения основан метод доказательства от противного. Суть этого метода состоит в том, что доказывают истинность теоремы, противоположной обратной, поскольку если эта теорема истинна, то и исходная теорема тоже верна.
Larax0819
OPTION BASE 1
DIM a(10) AS SINGLE, b(10) AS SINGLE, x(10) AS SINGLE
RANDOMIZE TIMER
FOR i = 1 TO 10
   a(i) = 30 * RND - 15
NEXT i
FOR i = 1 TO 10
   b(i) = 40 * RND - 20
NEXT i
CLS
PRINT "A", "B", "X"
FOR i = 1 TO 10
   IF a(i) = 0 THEN
      x(i) = 1E+10
   ELSE
      x(i) = b(i) / a(i)
   END IF
   PRINT a(i), b(i), x(i)
NEXT i

Тестовое решение:
A             B             X
-5.504717      19.41665     -3.527274
-5.233851     -11.24631      2.148764
-5.154725      2.927625     -.5679499
 5.057724     -8.649354     -1.710128
-6.304109     -19.25289      3.054023
-1.920151      6.061134     -3.156593
-10.34241      17.10881     -1.654238
 13.86053      .4965448      3.582438E-02
-4.931755      8.241055     -1.671019
 8.120502      8.78438       1.081753

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Есть текст- рядок который состоит из слов, пропусков и знаков препинания и заканчивается точкой. поменять местами первое и последнее слово. составить программу на языке паскаль​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Olgachalova111
Alexander2035
andre6807
Татьяна1856
dimari81
alekseysokolov29816
Андреевна-Арзуманян1109
Fateevsa9
Попова1271
osipovasalex5316
fucingprinces30
Olenkalebedeva4477
zaschitin48
Татьяна
zhmulyov-denis8