Калмыкова-Петрунина
?>

Всем , сильно и нужна ваша ! 1.дано слово: строка. написать программу, заменяющую букву т на к 2.написать программу, которая проверяет, является ли данный текст записью числа

Информатика

Ответы

denis302007
Program task;
var p:array[1..10] of integer;
      i, n2, n3, n4, n5:integer;
begin
       n2:=0; n3:=0; n4:=0; n5:=0; {n2 - n5 - колич. 2-ек, 3-ек и т.д.}
        writeln('Введите 10 элементов массива, отметки от 1 до 5');
        for i:=1 to 10 do {ввод исходных данных}
        begin
                 write('p[',i,'] = ');
                 readln(p[i])
         end;
         for i:=1 to 10 do  {решение, перебор таблицы и суммирование}
         begin
                 if p[i] = 2 then n2:=n2+1;
                 if p[i] = 3 then n3:=n3+1;
                 if p[i] = 4 then n4:=n4+1;
                 if p[i] = 5 then n5:=n5+1
          end;
          writeln('n2 = ',n2);  {вывод результатов}
          writeln('n3 = ',n3);
          writeln('n4 = ',n4);
          writeln('n5 = ',n5);
          writeln('всего оценок',n2+n3+n4+n5)
end.
olesyadeinega41

1)

так как в предложении 37 символов

37*2(так как каждый символ 2 байта) = 74 байта

байты переводим в биты получаем 74 * 8 = 592 бита

2)

20*32*16 = 10240 (количество символов в статье)

каждый символ кодируется 16-ю битами,

10240 * 16 = 163840 бит.

можно перевести в килобайты.

163840 бит/8 = 20480 байт

20480/1024 = 20 кб.

ответ: 20 килобайт.

3)

160 / 8 = 20. Итого 20 символов, т.к. в 1 байте - 8 бит.

4)

0,5*1024*8/256=16 бит

5)

Общий объём ста­тьи равен x · 64 · 48 · 16 бит = 48 Кбайт.

Сле­до­ва­тель­но, ко­ли­че­ство стра­ниц в ста­тье рав­ня­ет­ся:

x = (48 · 1024 · 8)/(64 · 48 · 16) = 8.

6)

80 * 25 = 2000 символов поместится на экране монитора.

Т.к в кодировке Unicode каждый символ кодируется 16 битами, то

2000 * 16 = 32 000 бит = 32 байта.

ответ: объем текста занимающего весь экран монитора в кодировке Unicode примерно 32 байта.

7)

40 * 32 * 4 = 5120 символов в сообщении.

5 Кбайт = 5120 байт.

5120 / 5120 = 1 байт, значит, на кодирование 1 символа отводится 8 бит.

Получается, в алфавите 2^8 = 256 символов.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Всем , сильно и нужна ваша ! 1.дано слово: строка. написать программу, заменяющую букву т на к 2.написать программу, которая проверяет, является ли данный текст записью числа
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

A2017
Coverplus30
Кедрин Карлен
chizhenkovd9
mberberoglu17
alexandergulyamov
Vrpeshka
КалюкМарасанов1026
Информатика 6 класс стр 35, упр6​
oksanashabanovadc3197
pifpaf85
annakuznetsova841
Vlad Petr531
elenalukanova
amayonova
Роман1406