sodrugestvo48
?>

Написать программу в языке c: дан текстовый файл. напечатать все строки, длина которых равна данному числу.

Информатика

Ответы

Neveselova
1. Вероятность вынуть первым красный карандаш определяется отношением количества красных карандашей к их общему числу, т.е. 2/4 или 1/2.
2. Теперь в коробке остался один красный карандаш, а всего карандашей - три. Вероятность вынуть красный карандаш равна 1/3.
3. Вероятность наступления обоих событий определяется произведением обоих вероятностей и составляет 1/2 × 1/3 = 1/6
Итак, два красных (а также два синих) карандаша можно вынуть с вероятностью 1/6.
Сумма всех вероятностей равна 1, с вероятностью 1/6 оба карандаша будут красные, 1/6 - синие, значит на долю события, когда карандаши будут разного цвета остается 1 - 1/6 - 1/6 = 2/3
gennadevna
1) файл паскаля приложен.
2) код на c#
        static void Main(string[] args)        {            int a, b;            a = Convert.ToInt32(Console.ReadLine());            b = Convert.ToInt32(Console.ReadLine());            if (a > 2)            {                Console.WriteLine(a / 2);                Console.WriteLine(b - 1);            }        }
3) Код на vb
dim a as integer = 0
dim b as integer = 0
a = cint(console.readline())
b = cint(console.readline())
if a > 2 then
console.writeline( a / 2)
console.writeline(b - 1)
end if

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в языке c: дан текстовый файл. напечатать все строки, длина которых равна данному числу.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Алиференко_Елена342
Bolshakova Shigorina
aninepp
vyborovvs
MArat
funny-furiya
Vova220
germanleon
yana2211
lavr74
ajuli2
bristolhouse20151001
Газинурович
Vladimirovna1370
Людмила Анна