david-arustamyan1
?>

Дана строка, написать программу, которая находит максимальное простое число (числа отделены пробелами) в строке и заменяет на него все слова, где есть цифры

Информатика

Ответы

seletan1

1)x = (input('x= '))

y = (input('y= '))

z = (input('z= '))

c = ((x % 3 == 0) and (y % 3 == 0) and (z % 3 == 0))

print(

else:

print

2)uses crt;

var x,y:real;

   f1,f2:boolean;

begin

clrscr;

writeln('Введите 2 числа:');

readln(x,y);

f1:=(x>2)and(y>3);

f2:=(x>1)and(y>-2);

writeln(f1);

write(f2);

readln

end.

3)uses crt;

var a,r:real;

 

begin

clrscr;

write('Введите сторону квадрата и радиус круга-> ');

readln(a,r)

if sqr(a)>pi*sqr(r) then write('У квадрата') else write('У круга');

readln;

end.

5)uses crt;

Var a, i, n, S: integer;

Begin

Write('Vvedite n '); readln(n);

S:=0;

For i:=40 to 140 do

 begin

 read(a);

 if (a mod 6 =0) then S:=S+a;

 end;

Writeln(S);

End.

Rakitin

Известны два расстояния: одно в километрах, другое—в футах(1 фут=0,45 м). Какое из расстояний меньше?

Program ss;
uses crt;
var
a,b,c,s,s1: integer;
Begin
clrscr;
Writeln('Введите расстояние в километрах:');
readln(a);
Writeln('Введите расстояние в футах');
readln(b);
writeln('Введите размер одного фута в метрах');
s:=a*1000;
s1:=c*b;

if s>s1 then
begin
write('Расстояние в футах меньше чем в км');
end
else
writeln('Расстояние в км меньше чем в футах');
writeln(' Программа завершена нажмите ');
readln;
End.

Известны две скорости: одна в километрах в час, другая—в метрах в секунду. Какая из скоростей больше?
program EvGeN;
var
kilom: real;
metr: real;
begin
kilom := metr * 1.6;
write('Введите скорость в км\ч: ');
readln(kilom);
write('Введите скорость в м\с: ');
readln(metr);
if kilom < metr then write('скорость в км\ч больше');
if kilom > metr then write('скорость в км\ч меньше');
if kilom = metr then write('скорость в км\ч равна скорости в м\ч');
end.

Даны радиус круга и сторона квадрата. У какой фигуры площадь больше
Program ploshcad;
var R,D,skr,skv:extended;
Begin
write('Введите радиус круга: '); readln®;
write('Введите сторону квадрата'); readln(D);
skr:=Pi*sqr®;
writeln('Площадь круга: ',skr:10:5);
skv:=sqr(D);
writeln('Площадь квадрата: ',skv:10:5);
If skr=skv then
writeln('Площади равный');
If skr>skv then
writeln('Площадь круга больше');
If skv<skr then writeln('Площадь квадрата больше');
readln;
End.

 Известны площади круга и квадрата. Определить:
a) Уместится ли круг в квадрате?
b) Уместится ли квадрат в круге?

Program prim;
Var a,r,s1,s2:real;
Begin
Write('введите площадь круга и квадрата');
Readln(s1, s2);
A:=sqrt(s2);
R:=sqrt(s/3.14);
If (r<a/2) then writeln (' круг уместится в квадрате')
Else writeln (' круг не уместится в квадрате');
If (a*sqrt(2))>(4*r) then writeln ('квадрат уместится в круге')
Else Writeln('квадрат не уместится в круге');
Readln
End.

Даны объёмы и массы двух тел из разных материалов. Материал какого из тел имеет большую плотность.
var v1,v2,m1,m2,p1,p2: real;
begin
writeln('Введите объем и массу первого тела');
readln(v1,m1);
writeln('Введите объем и массу второго тела');
readln(v2,m2);
p1:=v1/m1;
p2:=v2/m2;
if p1>p2 then begin
writeln('Плотность первого тела больше');
end;
if p1<p2 then begin
writeln('Плотность второго тела больше');
end
else if p1=p2 then begin
writeln('Плотности тел равны');
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дана строка, написать программу, которая находит максимальное простое число (числа отделены пробелами) в строке и заменяет на него все слова, где есть цифры
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Aivazyan
ukkavtodor6
Klochkov malakhov1974
чухловина209
dmitryshigin
AnnaChulyukanova3
drontox1031
suhovaab
ustinovda14
sergeymartyn56
kozak8824
Gainalii1912
тахирович_Игорь581
Мария591
Aleksandrivanovna