Напишите программу которая заменяет в символьной строке все точки на нули и все буквы х на единицы. например, из строки '..xx..x.' должна получиться строка '00110010’.
#include <iostream> #include <stdio.h> using namespace std;
int main(){ int y; cin>>y; y=y%12; switch (y){ case 4:{cout<<"Mouse"; break;} case 5:{cout<<"Bull";break;} case 6:{cout<<"Tiger";break;} case 7:{cout<<"Rabbit";break;} case 8:{cout<<"Dragon";break;} case 9:{cout<<"Snake";break;} case 10:{cout<<"Horse";break;} case 11:{cout<<"Goat";break;} case 0:{cout<<"Monkey";break;} case 1:{cout<<"Cock";break;} case 2:{cout<<"Dog";break;} case 3:{cout<<"Pig";break;} } cin.get(); cin.get(); return 0; }
rashad8985
02.06.2023
#include <iostream> #include <cstdlib> // содержит srand() и rand() #include <ctime> using namespace std;
int main() { int n=10; int mas[n] = {}; int tmp,j=0; cout<<"random number"; cout<<endl; // начальная установка генератора случ. чисел srand(time(NULL)); // заполнение массива случайными числами for (int i = 0; i < n; i++) { mas[i] = rand()/100; cout<<mas[i]<<" "; } cout<<endl; // перестановка элементов for (int i = 0; i < n/2; i++) { tmp=mas[i]; mas[i]=mas[2*(i+1)-1]; j=2*i; while (j>i) { mas[j+1]=mas[j]; j--; } mas[i+1]=tmp; } //"массив после замены" for (int i = 0; i < n; i++) cout<<mas[i]<<" "; cout<<endl; system("pause"); return 0; }
===== PascalABC.NET =====
begin
var s := ReadlnString;
for var i := 1 to s.Length do
case s[i] of
'.': s[i] := '0';
'x', 'X': s[i] := '1'
end;
Println(s)
end.