Yurevich1291
?>

Дан массив из десяти целых чисел. напишите программу подсчёта количества элементов этого массива, имеющих максимальное значение.​

Информатика

Ответы

Кристина_Memmedov

язык программирования какой?


Дан массив из десяти целых чисел. напишите программу подсчёта количества элементов этого массива, им
Lesnova_Kiseleva730
1) program ex;
 var i:integer ;mas:array [1..10] of integer;
 begin 
  for i:=1 to 10 do   
  begin    
   mas[i]:=random(9)+1;    
   if (mas[i] mod 2)=0 then     
    mas[i]:=mas[i]+1;   
  end;
 end. 
2)program ex;
var i:integer ;mas:array [1..10] of integer;
begin 
 for i:=1 to 10 do   
 begin    
  mas[i]:=random(9)+1;    
  if (mas[i] mod 2)=0 then     
   mas[i]:=0;   
  else
   mas[i]:=mas[i]*3;
 end;
end.
3)program ex;
var i:integer ;mas:array [1..10] of integer;
begin 
 for i:=1 to 10 do   
 begin    
  mas[i]:=random(9)+1;    
  if (i mod 2)=0 then     
   mas[i]:=(mas[i]*mas[i]);   
 end;
end.
4)program ex;
var i:integer ;mas:array [1..10] of integer;
begin 
 for i:=1 to 10 do   
 begin    
  readln(mas[i]); 
  if (mas[i]<0) then     
   mas[i]:=mas[i]*(-1);   
 end;
end.
menesmir
1) var a:array [1..10] of integer;
i:integer;
begin
writeln('Генерируем массив со случайными числами');
for i:=1 to 10 do begin
a[i]:=random(100)+1;
write(a[i],' ');
end;
writeln;
writeln('Выполняем действие');
for i:=1 to 10 do begin
if (i mod 2 = 0) then a[i]:=0 else a[i]:=a[i]*3;
write(a[i],' ');
end;
readln;
end.

2) var a:array [1..10] of integer;
i,k:integer;
begin
writeln('Генерируем массив со случайными числами');
for i:=1 to 10 do begin
a[i]:=random(100)+1;
write(a[i],' ');
end;
writeln;
writeln('Выполняем действие');
k:=a[1];
a[1]:=a[10];
a[10]:=k;
for i:=1 to 10 do write(a[i],' ');
readln;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дан массив из десяти целых чисел. напишите программу подсчёта количества элементов этого массива, имеющих максимальное значение.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

yana2211
papushinrv4985
aobuhta4
Lorik-lorik29
vik-2202
cheremetdiana
vadimpopov88
eshabunina
oldulo74
merx80
magazintrofey
badalovao256
priexali
Annabill1987
innaterenina
▲