ivanova229
?>

Склавиатуры вводится строка. составьте программу, которая «переворачивает» строку. пример: входные данные: кит; выходные данные: тик. только решение не такое, как здесь, нужно подробное.

Информатика

Ответы

Freelifecool797

program Hello;

var a,k:string;

var i:integer;

begin

 read(a);

 for i:=0 to length(a) do begin

   k := k+a[length(a)-i];    

 end;

 write(k);

end.

Объяснение:

заводим две переменных типа string(строковой тип данных)

а и к

и еще не забудем счетчик для цикла i

строковой тип данных это массив из символов,то есть мы можем извлекать из него элементы с цикла

объявим цикл for от 0 до длины нашей строки,которую возвращает функция length() и с конкатенации(сложения строк,например: 'a'+'b'= 'ab) добавляем к новой строке "к"  элемент length()-i строки а.

vlrkinn
А)
алг А
нач
  цел N = 10
  целтаб a[1:N]
  цел i, s
 
  нц для i от 1 до N
    вывод "a[",i,"] = "
    ввод a[i]
  кц
  вывод нс
 
  s:=a[3]+a[5]
  вывод "s = ", s, нс
кон

Б)
алг Б
нач
  цел M = 10
  целтаб a[1:M]
  цел i, max
 
  нц для i от 1 до M
    вывод "a[",i,"] = "
    ввод a[i]
  кц
  вывод нс
 
  max:=a[1]
  нц для i от 2 до M
    если a[i] > max то
      max:=a[i]
    все
  кц
  вывод "max = ",max,нс
кон

В)
алг В
нач
  цел M = 10
  целтаб a[1:M]
  цел i, k
 
  нц для i от 1 до M
    вывод "a[",i,"] = "
    ввод a[i]
  кц
  вывод нс
 
  k:=0
  нц для i от 1 до M
    если mod(a[i],6)=0 то
      k:=k+1
    все
  кц
  если k>0 то
    вывод "k = ",k,нс
  иначе
    вывод "Нет чисел, кратных 6"
  все
кон
Г)
алг Г
нач
  цел N = 10
  целтаб a[1:N]
  цел i, p
 
  нц для i от 1 до N
    вывод "a[",i,"] = "
    ввод a[i]
  кц
  вывод нс
 
  p:=1
  нц для i от 1 до N
    если mod(a[i],2)=0 то
      p:=p*a[i]
    все
  кц
  вывод "p = ",p,нс
кон
Ильдар-Кугай
А)
алг А
нач
  цел N = 10
  целтаб a[1:N]
  цел i, s
 
  нц для i от 1 до N
    вывод "a[",i,"] = "
    ввод a[i]
  кц
  вывод нс
 
  s:=a[3]+a[5]
  вывод "s = ", s, нс
кон

Б)
алг Б
нач
  цел M = 10
  целтаб a[1:M]
  цел i, max
 
  нц для i от 1 до M
    вывод "a[",i,"] = "
    ввод a[i]
  кц
  вывод нс
 
  max:=a[1]
  нц для i от 2 до M
    если a[i] > max то
      max:=a[i]
    все
  кц
  вывод "max = ",max,нс
кон

В)
алг В
нач
  цел M = 10
  целтаб a[1:M]
  цел i, k
 
  нц для i от 1 до M
    вывод "a[",i,"] = "
    ввод a[i]
  кц
  вывод нс
 
  k:=0
  нц для i от 1 до M
    если mod(a[i],6)=0 то
      k:=k+1
    все
  кц
  если k>0 то
    вывод "k = ",k,нс
  иначе
    вывод "Нет чисел, кратных 6"
  все
кон
Г)
алг Г
нач
  цел N = 10
  целтаб a[1:N]
  цел i, p
 
  нц для i от 1 до N
    вывод "a[",i,"] = "
    ввод a[i]
  кц
  вывод нс
 
  p:=1
  нц для i от 1 до N
    если mod(a[i],2)=0 то
      p:=p*a[i]
    все
  кц
  вывод "p = ",p,нс
кон

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Склавиатуры вводится строка. составьте программу, которая «переворачивает» строку. пример: входные данные: кит; выходные данные: тик. только решение не такое, как здесь, нужно подробное.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vik1223
koldunovan
zoocenterivanoff51
Anna_Kamil
juliavovo
Lerkinm
Shevchenko
starabanov
mposte
mariapronina720126
vettime625
Вадимовна
Олег2014
Takhmina-Komarova1415
DudukinSerega2507834