program sailor;
var
a, b, c, d, e, f: integer;
begin
read(a, b, c, d, e, f);
if (b - a + 1 > d - c + 1) and (b - a + 1 > f - e + 1) then
write('1');
if (d - c + 1 > b - a + 1) and (d - c + 1 > f - e + 1) then
write('2');
if (f - e + 1 > b - a + 1) and (f - e + 1 > d - c + 1) then
write('3');
end.
Объяснение:
program sailor; // Название программы
var
a, b, c, d, e, f: integer; // Целочисленные переменные, отвечающие за часы в 1 - 3 дни
begin // Начало программы
read(a, b, c, d, e, f); // Считываем часы с клавиатуры
if (b - a + 1 > d - c + 1) and (b - a + 1 > f - e + 1) then // Если разница между часами первого дня + 1 > разницы между часами второго и третьего дней, тогда
write('1'); // Выводим 1
if (d - c + 1 > b - a + 1) and (d - c + 1 > f - e + 1) then // Если разница между часами второго дня + 1 > разницы между часами первого и третьего дней, тогда
write('2'); // Выводим 2
if (f - e + 1 > b - a + 1) and (f - e + 1 > d - c + 1) then // Если разница между часами третьего дня + 1 > разницы между часами первого и второго дней, тогда
write('3'); // Выводим 3
end. // Конец программы
Поделитесь своими знаниями, ответьте на вопрос:
Склавиатуры вводится строка с грамматическими ошибками. составьте программу, позволяющую проверить правописание. выведите на экран количество допущенных ошибок и исправленную строку.
9 задание: 7
10 задание:
Иванов || 2000 || 240Петров || 2000 || 230Сидоров || 2001 || 200Козлов || 1998 || 200Объяснение:
9 задание:
(Очки команды "Помидор" < 3) ИЛИ (Победитель = "Звёздочка")
Дата матча || Очки команды "Звёздочка" || Очки команды "Помидор" || Победитель
18.11 2012 || 2 || 1 || "Звёздочка" = 119.11 2012 || 3 || 4 || "Помидор"20.11 2012 || 3 || 1 || "Звёздочка" = 221.11 2012 || 2 || 1 || "Звёздочка" = 322.11 2012 || 1 || 2 || "Помидор" = 423.11 2012 || 2 || 1 || "Звёздочка" = 524.11 2012 || 0 || 2 || "Помидор" = 625.11 2012 || 2 || 3 || "Помидор"26.11 2012 || 1 || 0 || "Звёздочка" = 710 задание:
Сортировка по убыванию по полю " ".
Было:
Иванов || 2000 || 240Сидоров || 2001 || 200Петров || 2000 || 230Козлов || 1998 || 200Стало:
Иванов || 2000 || 240Петров || 2000 || 230Сидоров || 2001 || 200Козлов || 1998 || 200Идём от большего к меньшему.