Склавиатуры вводится целое число. составьте программу , которая позволяет найти количество цифр в этом числе указания. нужно ввести число, преобразовать число в строку, вычислить длину строки и вывести результат.9 класс. !
Program n1; function isprost(x: integer): boolean; var i: integer; begin if x<2 then isprost:=false else begin isprost:=true; for i := 2 to round(sqrt(x)) do if x mod i = 0 then isprost:=false; end; end; var a,b,i,sum: integer; p: real; begin writeln('введите границы отрезка [a;b] (предполагается, что числа натуральные)'); write('a='); readln(a); write('b='); readln(b); p:=1; sum:=0; if(a<=0) or (b<=0) then write('ошибка, числа не натуральные') else begin writeln('простые числа на отрезке [',a,';',b,']'); for i:=a to b do if isprost(i) then begin p:=p*i; sum:=sum+i; write(i,' '); end; writeln; writeln('их сумма: ',sum); writeln('их произведение: ',p); end; end.
karpachevamarina
16.08.2022
// PascalABC.NET 3.3 // Cборка 1590 от 03.12.2017
begin var (dr,mr,gr):=ReadInteger3('Введите день, номер месяца и год рождения->'); var (ds,ms,gs):=ReadInteger3('Введите какой день, номер месяца и год на данный момент->'); var kol:=gs-gr; if ((ms<mr) and (ds<dr)) or ((ms=mr) and (ds<dr)) then dec(kol); Println('Количество лет->',kol); end.
Пример(1): Введите день, номер месяца и год рождения-> 2 1 1920 Введите какой день, номер месяца и год на данный момент-> 18 9 2013 Количество лет-> 93
Пример(2): Введите день, номер месяца и год рождения-> 31 12 2001 Введите какой день, номер месяца и год на данный момент-> 1 1 2033 Количество лет-> 31
===== PascalABC.NET =====
begin
ReadInteger.ToString.Length.Println
end.