Сергеевна-Иван1045
?>

Python в школе решили набрать три новых класса. так как занятия по у них проходят в одно и то же время, было решено выделить кабинет для каждого класса и купить в них новые парты. за каждой партой может сидеть не больше двух учеников. известно количество учащихся в каждом из трёх классов. сколько всего нужно закупить парт чтобы их хватило на всех учеников? программа получает на вход три натуральных числа: количество учащихся в каждом из трех классов..

Информатика

Ответы

Николаев

При его решении сначала вычисляют дискриминант по формуле.

Если D > 0, то квадратное уравнение имеет два корня; если D = 0, то 1 корень; и если D < 0, то делают вывод, что корней нет.

Если D > 0, то квадратное уравнение имеет два корня; если D = 0, то 1 корень; и если D < 0, то делают вывод, что корней нет.Таким образом, программа для нахождения корней квадратного уравнения может иметь три ветви условного оператора.

Если D > 0, то квадратное уравнение имеет два корня; если D = 0, то 1 корень; и если D < 0, то делают вывод, что корней нет.Таким образом, программа для нахождения корней квадратного уравнения может иметь три ветви условного оператора.Функция float() преобразует переданный ей аргумент в вещественное число.

firsova5911

1-е Задание:

Program PRG;

var

a, b, c, e, x, y, num, den: real;

function calc( a, b, c, e, x: real ): real;

begin

 num := ((( abs(sin(x ** 3))) + a) * (e ** a));

 den := (exp(ln((b ** 2) + (c ** 2)) / 3));

 y :=  num / den;

 Result := y;

 write('Answer is: ', y);

 writeln();

end;

function entNums (): real;

begin

 write ('Enter a: '); readln (a);

 write ('Enter b: '); readln (b);

 write ('Enter c: '); readln (c);

 write ('Enter e: '); readln (e);

 write ('Enter x: '); readln (x);

 writeln();

end;

begin

   entNums();

calc( a, b, c, e, x );

end.

2-е Задание:

Program  

var wallWid, wallHeight, winHeight, winWid, doorWid, doorHeight, fourWalls, door, win, total: real;

function getFourWalls( wallWid, wallHeight: real ): real;

   begin

       fourWalls := (wallHeight * wallWid) * 4;

       Result := fourWalls;

   end;

function getDoorSize( doorHeight, doorWid: real ): real;

   begin

       door := doorHeight * doorWid;

       Result := door;

   end;

function getWinSize( winHeight, winWid: real ): real;

   begin

       win := winHeight * winWid;

       Result := win;

   end;

function getWalls(): real;

   begin

       total := (fourWalls - ( door + win )) / 10000;

       Result := total;

       write(' You need ', total, ' m² of wallpaper!');

       writeln();

   end;

function enterSizes(): real;

   begin

       writeln();

       write (' Enter width of the wall (in cm): '); readln (wallWid);

 write (' Enter height of the wall (in cm): '); readln (wallHeight);

 write (' Enter width of the window (in cm): '); readln (winWid);

 write (' Enter hight of the window (in cm): '); readln (winHeight);

 write (' Enter width of the door (in cm): '); readln (doorWid);

 write (' Enter height of the doot (in cm): '); readln (doorHeight);

 writeln();

   end;

begin

   enterSizes();

   getFourWalls( wallWid, wallHeight );

   getDoorSize( doorHeight, doorWid );

   getWinSize( winHeight, winWid );

   getWalls();

end.

Блок-схемы легко можешь составить глядя на коды программ)

Удачи)

 

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Python в школе решили набрать три новых класса. так как занятия по у них проходят в одно и то же время, было решено выделить кабинет для каждого класса и купить в них новые парты. за каждой партой может сидеть не больше двух учеников. известно количество учащихся в каждом из трёх классов. сколько всего нужно закупить парт чтобы их хватило на всех учеников? программа получает на вход три натуральных числа: количество учащихся в каждом из трех классов..
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Timurr007
MelnikovaIvanovna
Andreevich
Wunkamnevniki13438
Анастасия1097
Конычева-музей&quot;260
NIKOLAI
ogonizoloto
juliaWinter
Александрович
АлександровнаВладимирович1424
korneevaa
eremenkou
lenalevmax7937