kenni19868
?>

Переделать с pascal на python uses crt; var x1, y1, x2, y2, x3, y3, x4, y4, k: longint; begin read (x1, y1, x2, y2, x3, y3, x4, y4); k: =0; if (x2-x1)*(x4-x1)+(y2-y1)*(y4-y1)=0 then k: =k+1; if (x1-x2)*(x3-x2)+(y1-y2)*(y3-y2)=0 then k: =k+1; if (x2-x3)*(x4-x3)+(y2-y3)*(y4-y3)=0 then k: =k+1; if (x1-x4)*(x3-x4)+(y1-y4)*(y3-y4)=0 then k: =k+1; write (k); readkey; end.

Информатика

Ответы

veraplucnika

Использовать латиницу

 

#include <iostream>
using std::cout;
using std::cin;
using std::endl;
#include <cstring>
using std::strlen;
using std::strtok;

int main()
{
    char s[100];
    char *temp1;
    char *temp2;

    cout << "Enter the name and surname: ";
    cin.getline(s, 100);

    temp1 = strtok(s, " ");
    temp2 = strtok(NULL, " ");

    if(*(temp1 + strlen(temp1) - 1) == *(temp2 + strlen(temp2) - 2))
    {
        cout << "true" << endl;
    }
    else
        cout << "false" << endl;

   return 0;
}


Умоляю, составить с клавиатуры одной строкой вводят имя и фамилию через пробел.составьте программу,к
kbndbyb6

Program Program1;
Var
a:array [1..10] of integer;
i,min,max, Nmin, Nmax:integer;

//Процедура рекурсивной инвресии массива
procedure InvertMas(nac,kon:integer);
var
temp:integer;
begin
temp:=a[nac];
a[nac]:=a[kon];
a[kon]:=temp;
if nac+1<kon-1 then InvertMas(nac+1,kon-1);
end;

begin
randomize;
//Заполняем массив случайнами числами и выводим его на экран
writeln('Массив до инверсии:');
for i:=1 to 10 do
begin
a[i]:=random(100);
writeln('a['+inttostr(i)+']='+inttostr(a[i]));
end;
//Находим самый левый минимальный элемент в первой половине массива и номер этого элемента
Nmin:=1;
min:=a[Nmin];
for i:=1 to 5 do
if min>a[i] then
begin
min:=a[i];
Nmin:=i;
end;
//Находим самый правый максимальный элемент во второй половине массива и номер этого элемента
Nmax:=10;
max:=a[Nmax];
for i:=10 downto 6 do
if max<a[i] then
begin
max:=a[i];
Nmax:=i;
end;

writeln;
writeln('Инвертируем часть массива с '+inttostr(Nmin)+' по '+inttostr(Nmax)+' элемент');
//Инвертируем часть массива с Nmin по Nmax
invertmas(Nmin,Nmax);

//Выводим массив после инверсии на экран
writeln;
writeln('Массив после инверсии:');
for i:=1 to 10 do writeln('a['+inttostr(i)+']='+inttostr(a[i]));

end.


Необходимо составить программу с использованием рекурсии замечание: под инвертированием понимают пер

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Переделать с pascal на python uses crt; var x1, y1, x2, y2, x3, y3, x4, y4, k: longint; begin read (x1, y1, x2, y2, x3, y3, x4, y4); k: =0; if (x2-x1)*(x4-x1)+(y2-y1)*(y4-y1)=0 then k: =k+1; if (x1-x2)*(x3-x2)+(y1-y2)*(y3-y2)=0 then k: =k+1; if (x2-x3)*(x4-x3)+(y2-y3)*(y4-y3)=0 then k: =k+1; if (x1-x4)*(x3-x4)+(y1-y4)*(y3-y4)=0 then k: =k+1; write (k); readkey; end.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

balabinatanya7174
abuzik
natalya2321
Мартынова1638
suhanowaswetlana
shchepinasm
lubavarif83
katrin819
shmanm26
Snimshchikov465
Olga Arutyunyan
mail9
sorokinae
Shtorm-Shoe
antonkovalev89