Shamsulo
?>

Питон. напишите программу, которая заполняет массив из 20 элементов случайными целыми числами на отрезке [50; 150] и находит в нём минимальный из чётных элементов и его номер.

Информатика

Ответы

lbeglarova6
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  for var a:=1 to 10 do begin
    Writeln('Длина стороны ',a,' см');
    for var b:=1 to 10 do
      Writeln('Вторая сторона ',b:2,', периметр ',2*(a+b):2,
          ', площадь ',a*b:3)
    end
end.

Результат
Длина стороны 1 см
Вторая сторона  1, периметр  4, площадь   1
Вторая сторона  2, периметр  6, площадь   2
Вторая сторона  3, периметр  8, площадь   3
Вторая сторона  4, периметр 10, площадь   4
Вторая сторона  5, периметр 12, площадь   5
Вторая сторона  6, периметр 14, площадь   6
Вторая сторона  7, периметр 16, площадь   7
Вторая сторона  8, периметр 18, площадь   8
Вторая сторона  9, периметр 20, площадь   9
Вторая сторона 10, периметр 22, площадь  10
Длина стороны 2 см
Вторая сторона  1, периметр  6, площадь   2
Вторая сторона  2, периметр  8, площадь   4
Вторая сторона  3, периметр 10, площадь   6
Вторая сторона  4, периметр 12, площадь   8
Вторая сторона  5, периметр 14, площадь  10
Вторая сторона  6, периметр 16, площадь  12
Вторая сторона  7, периметр 18, площадь  14
Вторая сторона  8, периметр 20, площадь  16
Вторая сторона  9, периметр 22, площадь  18
Вторая сторона 10, периметр 24, площадь  20
Длина стороны 3 см
Вторая сторона  1, периметр  8, площадь   3
Вторая сторона  2, периметр 10, площадь   6
Вторая сторона  3, периметр 12, площадь   9
Вторая сторона  4, периметр 14, площадь  12

Длина стороны 10 см
Вторая сторона  1, периметр 22, площадь  10
Вторая сторона  2, периметр 24, площадь  20
Вторая сторона  3, периметр 26, площадь  30
Вторая сторона  4, периметр 28, площадь  40
Вторая сторона  5, периметр 30, площадь  50
Вторая сторона  6, периметр 32, площадь  60
Вторая сторона  7, периметр 34, площадь  70
Вторая сторона  8, периметр 36, площадь  80
Вторая сторона  9, периметр 38, площадь  90
Вторая сторона 10, периметр 40, площадь 100
KononovaMaiorov453
1. Определим размер алфавита, т.е. количество используемых символов.
20 букв и 9 цифр - это 29 символов. Чтобы закодировать 29 разных символов нужно 5 бит ( 2⁴ < 29 < 2⁵ ).
2. Определим длину личного кода.
В коде 15 символов, каждый символ занимает 5 бит. Всего потребуется 5×15=75 бит. Поскольку код занимает целое число байт, переводит 75 бит в байты. 75/8 = 9.375 ≈ 10 байт.
3. Номер отдела можно закодировать 1 байтом (в байт помещается число от 0 до 255).
4. Найдем количество дополнительных байт.
На пропуске 20 байт, из них 10 заняты кодом, 1 - номером отдела, остаются 20-10-1 = 9 байт.

ответ: 9

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Питон. напишите программу, которая заполняет массив из 20 элементов случайными целыми числами на отрезке [50; 150] и находит в нём минимальный из чётных элементов и его номер.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

prostopo4ta29
nyuraborova89
александр496
dokurova634
Nikolaevna382
tatyanaryzhkova
andrew55588201824
ba5-m
zoyalexa495
козлов
Андрей_Станиславовна
mariy-inkina8
stsnab
alyonafialka
Nikolaevna Malika1511
▲