evainvest1
?>

Вкомбинаторике при вычислении количества сочетаний из n элементов по k используется формула( на изображении напишите код программы, используя функцию для вычисления кол-ва сочетаний. язык программирования - python

Информатика

Ответы

brand
Const n=20;
var a:array[1..n]of integer;
i,b,k,c,f,g,h:integer;
begin
for i:=1 to n do a[i]:=Random(70)-20;
for i:=1 to n do
write(a[i],' ');
writeln;
for i:=1 to n do begin
if (a[i] mod 5 = 0) and (a[i] mod 10<>0) or (a[i]=50) then begin
b:=i;
for b:=i to (n-1) do
a[i]:=a[i+1];
end; end;
for i:=1 to n do
write(a[i],' ');
write('введите к ');
read(k);
for i:=1 to n do begin
if a[i] mod i = 0 then begin
c:=i;
for i:=n downto c+1 do begin
a[i]:=a[i-1];
a[c+1]:=k;
end;end;end;
for i:=1 to n do
write(a[i],' ');
writeln;
f:=0; g:=0;
for i:=n downto 1 do begin
if (a[i]>0) then f:=i;
end;
if a[f]=0 then write('нет положительных ');
for i:=n downto 1 do begin
if (a[i]<0) then g:=i;
end;
if (a[g]=0) then write('нет отрицательных ');
if (a[f]<>0) and (a[g]<>0) then begin
h:=a[f]; a[f]:=a[g]; a[g]:=h; end;
for i:=1 to n do
write(a[i],' ');
writeln;
end.
krasnova1977
Такое задание уже было. Я на него отвечал, думаю модераторы не против, если свой же ответ здесь предоставлю)
  Только первых три

Задача 1:
var p: array[1..10] of integer;  
i:integer;
count:integer;
begin
for i:=1 to 10 do read(p[i]);
write('Сколько цифр массива хотите видеть? -> '); 
readln(count);
for i:=1 to count do write(p[i]:3);
end.

Задача 2:

var arr: array[1..10] of integer;   
i:integer;    
s:integer;    
count:integer;
begin
for i:=1 to 10 do
begin
arr[i]:=Random(-10,10);
if(arr[i]<0) then
begin
writeln(arr[i]:4);
s:=s+arr[i];
count:=count+1;
end;
end;
writeln('Среднее значение = ', s/count);
end.

Задача 3:

var arr: array[1..10] of integer;    
i:integer;    
crat:integer;    
id:integer;       
begin   
for i:=1 to 10 do   
begin   
read(arr[i]);   
crat:=arr[i] mod 3;   
if(crat = 0) then   
begin   
id:=arr[i];     
if(arr[i] = id) then writeln('Id = ', i:2);    
end;   
end;   
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вкомбинаторике при вычислении количества сочетаний из n элементов по k используется формула( на изображении напишите код программы, используя функцию для вычисления кол-ва сочетаний. язык программирования - python
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

misstimarina2016
TSKaraulova
vera-spicina
Telenkovav
georgegradoff122
olartamonov6
kep92
smileystyle
РостиславовичЮлия1147
annaar497
sergeystepanov231
expozition
miyulcha8077
ВитальевичЕвгеньевич346
Vladimir-Tamara1359