Maksim Dmitrii1579
?>

Написать программу в python задан двумерный массив а из 3-х строк и 5-и столбцов. составить программу, которая организует одномерный массив, каждый элемент которого есть количество положительных элементов исходного массива в столбце. вычислить произведение элементов полученного массива.

Информатика

Ответы

Михаил736

Объяснение:

Обозначим заданный двумерный массив через A, искомый одномерный - через В, произведение всех элементов этого массива - M. Тогда:

B=[ ]

M=1

for i in range(5):

   n=0

   for j in range(3):

       if A[ j ][ i ]>0:

           n+=1

   B.append(n)

   M*=n

print(B,M)

Дмитрий74

program Vozrasr;



var


 AGE: integer;//Переменная возраста



begin


 writeln('Введите любое число от 1 до 120');


 Readln(AGE); //Ввод возраста


 if (AGE < 1) or (AGE > 120) then


begin


   writeln('ERROR!')


end


 else


 begin


   case AGE of  //для чисел от 11 до 20 создаем отд-ый кейс


     11..20: Writeln('ответ: Мне ', AGE, ' лет');


   Else    //иначе если они не входят в диапазон от [11..20], то выполняется второй кейс


     begin


       case AGE mod 10 of     //делим на 10 и получаем остаток =


         1: Writeln('ответ: Мне ', AGE, ' год');


         2..4: Writeln('ответ: Мне ', AGE, ' года');


         0, 5..9: Writeln('ответ: Мне ', AGE, ' лет');


       end;


     end;


   end;


end;


end.

cherkashenko87543

ответ: \overline A \lor \overline B.

Пошаговое объяснение:

Во-первых, как можно заметить, от C значение функции не зависит.

Особенно это хорошо видно на последних двух строчках. Если убрать переменную C, то получиться таблица из 4 строк:

A B F

0 0 1

0 1  1

1  0 1

1  1 0

Это таблица истинности для отрицания И:  \overline{A \land B} = \overline A \lor \overline B - ответ.

На этом можно было бы остановиться (проверить по таблице истинности с учётом бесполезного С), но сделаем ещё кое-что - выведем это шаг за шагом, докажем, что С - бесполезная и никому не нужная переменная.

Запишем то же выражение в совершенной конъюнктивной нормальной форме. Выберем стоки, которые обращают выражение в Ложь.

A B C F

1   1 0 0

1   1  1 0

Две строки - две скобки. Единица в таблице означает отрицание переменной в скобке. Получаем F = (\overline A \lor \overline B \lor \overline C) \land (\overline A \lor \overline B \lor C).

Тут уже видно, что переменная С на результат не влияет. Упростим и приведём это к выражению выше.

(\overline A \lor \overline B \lor \overline C) \land (\overline A \lor \overline B \lor C) = (\overline A \lor \overline B \lor \overline C) \land \overline A \lor (\overline A \lor \overline B \lor \overline C) \land \overline B \lor (\overline A \lor \overline B \lor \overline C) \land C =

= \overline A \land \overline A \lor \overline B \land \overline A \lor \overline C \land \overline A \lor \overline A \land \overline B \lor \overline B \land \overline B \lor \overline C \land \overline B \lor \overline A \land C \lor \overline B \land C \lor \overline C \land C =

= \overline A \lor \overline B \land \overline A \lor \overline C \land \overline A \lor \overline A \land \overline B \lor \overline B \lor \overline C \land \overline B \lor \overline A \land C \lor \overline B \land C \lor 0 =

= \overline A \lor \overline B \lor [(\overline B \land \overline A) \lor (\overline A \land \overline B)] \lor [(\overline C \land \overline A) \lor(\overline A \land C)] \lor [(\overline C \land \overline B) \lor (\overline B \land C)] =

= \overline A \lor \overline B \lor (\overline A \land \overline B) \lor \overline A \land (\overline C \lor C) \lor \overline B \land (\overline C \lor C) =

= \overline A \lor \overline B \lor (\overline A \land \overline B) \lor \overline A \lor \overline B =

= \overline A \lor \overline B \lor (\overline A \land \overline B) =

= [(\overline A \lor \overline A) \land (\overline A \lor \overline B)] \lor \overline B =

= [\overline A \land (\overline A \lor \overline B)] \lor \overline B =

= (\overline A \lor \overline B ) \land (\overline A \lor \overline B \lor \overline B) =

= (\overline A \lor \overline B ) \land (\overline A \lor \overline B) =

= \overline A \lor \overline B - ответ.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в python задан двумерный массив а из 3-х строк и 5-и столбцов. составить программу, которая организует одномерный массив, каждый элемент которого есть количество положительных элементов исходного массива в столбце. вычислить произведение элементов полученного массива.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mariokhab
UvarovAndrei
yusovd291
Marinanagornyak
retropluse832
ksoboleva
svetsalikowa
alexseyzyablov
Valentinovna
tsigankova2018
ur101679
ldfenix87
donertime8
goldenshtein33333
laktionova-natal
▲