Поделитесь своими знаниями, ответьте на вопрос:
Питон даша часто забывала свой пароль от codeforces, поэтому она решила записать его в тетрадку. но она испугалась, что злоумышленник сможет подсмотреть ее пароль, зайти под ее логином, и украсть все ее решения. поэтому она решила разделить пароль на две части, и записать их отдельно: одну часть в тетрадку по , а другую — в тетрадку по языку. даша разделила пароль следующим образом. буквы с нечетными номерами (первая, третья, и т. д.) она записала в первую тетрадку, а буквы с четными номерами (вторая, четвертая, и т. д.) — во вторую тетрадку. теперь даша просит вас написать программу, которая по двум строкам, записанным в тетрадки, восстанавливает ее пароль. входные данные ввод содержит две строки, первая строка — это буквы пароля с нечетными номерами, вторая строка — это буквы пароля с четными номерами. обе строки не пустые, состоят только из букв, и имеют длину не больше 10. выходные данные выведите одну строку — пароль даши. примеры входные данныескопировать pswr asod выходные данныескопировать password входные данныескопировать qet wr выходные данныескопировать qwert
a: array[1..1000,1..1000] of integer;
i,j,s,n,m: integer;
begin;
write ('Введите количество строк: ');
readln (n);
write ('Введите количество столбцов: ');
readln (m);
s:=0;
for i:=1 to n do begin
for j:=1 to m do begin
a[i,j]:=random(-20,20);
write (a[i,j]:4);
end;
writeln;
if a[i,m] >= 0
then s:=s+a[i,m];
end;
writeln;
writeln ('Сумма положительных элементов последнего столбца = ',s);
end.
------------------------Результат:-------------------------
Введите количество строк: 5
Введите количество столбцов: 4
-20 14 10 13
0 -17 19 -4
-1 16 18 17
10 -8 -15 16
5 18 3 9
Сумма положительных элементов последнего столбца = 55