Баринова
?>

Составить программу, которая определяет, принадлежит ли точка с некоторыми координатами заштрихованной области, изображенной на рисунке (pascal)

Информатика

Ответы

asemchenko
Const
  MAX_SIZE = 10;
 
var
  a: array[1..MAX_SIZE] of integer;
  i, size: integer;
 
procedure delete_odd_elements();
var i, j: integer;
begin
  i := 1;
  repeat
    if odd(a[i]) then
    begin
      dec(size);
      for j := i to size do
        a[j] := a[j + 1]
    end
    else inc(i);
  until i > size;
end;
 
begin
  writeln('Исходный массив: ');
  size := MAX_SIZE;
  for i := 1 to size do
  begin
    a[i] := random(100);
    write(a[i] : 3);
  end;
  delete_odd_elements;
  writeln;
  writeln('Полученный массив: ');
  for i := 1 to size do
    write(a[i] : 3);
end.
Демидова Красноцветов
Основные сочетания клавиш
CTRL+C: копирование
CTRL+X: вырезание
CTRL+V: вставка
CTRL+Z: отмена действия
DELETE: удаление
SHIFT+DELETE: удаление выбранного объекта без возможности восстановления, не помещая объект в корзину
CTRL с перетаскиванием объекта: копирование выделенного объекта
CTRL+SHIFT с перетаскиванием объекта: создание ярлыка для выбранного объекта
Клавиша F2: переименование выбранного объекта
CTRL+СТРЕЛКА ВПРАВО: перемещение точки ввода в начало следующего слова
CTRL+СТРЕЛКА ВЛЕВО: перемещение точки ввода в начало предыдущего слова
CTRL+СТРЕЛКА ВНИЗ: перемещение точки ввода в начало следующего абзаца
CTRL+СТРЕЛКА ВВЕРХ: перемещение точки ввода в начало предыдущего абзаца
CTRL+SHIFT + клавиши со стрелками: выделение блока текста
SHIFT + клавиши со стрелками: выбор нескольких объектов в окне или на рабочем столе, а также выделение текста в документе
CTRL+A: выделение всего документа
Клавиша F3: поиск файла или папки
ALT+ВВОД: просмотр свойств выбранного объекта
ALT+F4: закрытие активного окна или завершение работы активной программы
ALT+ВВОД: просмотр свойств выбранного объекта
ALT+ПРОБЕЛ: вызов контекстного меню активного окна
CTRL+F4: закрытие активного документа в приложениях, в которых одновременно можно открыть несколько документов
ALT+ТАБУЛЯЦИЯ: переход между открытыми объектами
ALT+ESC: просмотр объектов в том порядке, в котором они были открыты
Клавиша F6: поочередный просмотр элементов интерфейса в окне или на рабочем столе
Клавиша F4: отображение панели адресов в папке «Мой компьютер» или в обозревателе Windows Explorer
SHIFT+F10: вызов контекстного меню для выделенного элемента
ALT+ПРОБЕЛ: вызов системного меню для активного окна
CTRL+ESC: вызов меню «Пуск»
ALT+подчеркнутая буква в названии меню: вызов соответствующего меню
Подчеркнутая буква в имени команды открытого меню: выполнение соответствующей команды
Клавиша F10: активация строки меню в используемой программе
СТРЕЛКА ВПРАВО: вызов следующего меню справа или подменю
СТРЕЛКА ВЛЕВО: вызов следующего меню слева или закрытие подменю
Клавиша F5: обновление активного окна
Клавиша BACKSPACE: просмотр содержимого папки, расположенной выше на один уровень в каталоге «Мой компьютер» или обозревателе Windows Explorer
Клавиша ESC: отмена выполняемого задания
SHIFT при загрузке компакт-диска в привод для компакт-дисков: предотвращение автоматического воспроизведения компакт-диска
CTRL+SHIFT+ESC: вызов диспетчера задач

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, которая определяет, принадлежит ли точка с некоторыми координатами заштрихованной области, изображенной на рисунке (pascal)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

inikonovich
o-pavlova-8635
николаевич-Елена988
semenoffufc8
M10M11M12
Bogataya Vladimir318
Yurevich
Sokolova-Shcherbakov
sakalrip
brendacepedam
yda659
shumeikoElena362
Ольга тимур
AleksandrovnaIgor
batalerka391