Pochkun-Oleg
?>

Сформировать двумерный массив размером 5x8, состоящий из случайных трёхзначных чисел. найти сумму элементов во второй строке и седьмом столбце. написать программу)

Информатика

Ответы

Paikina Natalya30

===== PascalABC.NET =====

begin

 var m := MatrRandom(5, 8, 100, 999);

 m.Println(4);

 Println('Сумма по второй строке', m.Row(1).Sum);

 Println('Сумма по седьмому столбцу', m.Col(6).Sum)

end.


Сформировать двумерный массив размером 5x8, состоящий из случайных трёхзначных чисел. найти сумму эл
Dlyamila

const n = 12;
var
  a: array[1..n] of integer;
  i, count, s, max: integer;
begin
  write('Массив до: ');
  for i := 1 to n do begin
    a[i] := random(19) - 8;
    write(a[i], ' ');
    if(a[i] > max) then max := a[i];
    if(a[i] > 3) then inc(count) else
    if(a[i] < 0) then begin
      s := s + a[i];
      a[i] := i;
    end;
  end;
  writeln;
  write('Массив после: ');
  for i := 1 to n do write(a[i], ' ');
  writeln;
  writeln('1) Кол-во эл. в массиве,значения которых > 3: ', count);
  writeln('2) Сумма всех отрицательных эл. массива: ', s);
  writeln('3) Макс. элемент: ', max);
end.

Kochetova92

Задание недоопределено, непонятно с 1 или с любого числа вычислять, непонятно, последовательных чисел или произвольных.

Я предложу решение следующей задачи

Составить программу вычисления произведения ПОСЛЕДОВАТЕЛЬНЫХ чисел натурального рада, начиная с N1, заканчивая N2. N1 и N2 вводятся с клавиатуры. 

 

Решение будет такое

П=1;  // здесь будем накапливать наше произведение

Ввод(N1, N2);

Если N2<N1 Тогда

    Сообщить("Неверные исходные данные!");

     Возврат;

КонецЕсли;

 

Для ц=N1 по N2 цикл

      П=П*ц;

КонецЦикла;

 

Сообщить("Произведение от "+N1+" до "+N2+" равно "+П);

 

Всё!

 

Ты не указал язык, которым владеешь, поэтому код написал на псевдоязыке, который ты без проблем переведёшь на известный тебе.

 

Успехов! В следующий раз более корректно и внимательно формулируй условие задачи.

 

 

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Сформировать двумерный массив размером 5x8, состоящий из случайных трёхзначных чисел. найти сумму элементов во второй строке и седьмом столбце. написать программу)
Ваше имя (никнейм)*
Email*
Комментарий*
▲