Fruktova Gazaryan
?>

Python написать программу, которая запрашивает число, и если оно 4597 печатает "как хорошо" иначе "иди, учи информатику"

Информатика

Ответы

lirene

Объяснение:

a = int(input("Введите число: "))

if a == 4597:

   print("Как хорошо")

else:

   print("Иди, учи информатику")

mariy-y34

n =  int(input('Введите какое-то число: '))

if n == 4597:

   print('Как хорошо')

else:

   print('Иди, учи информатику')

#иногда на знаниях слетают табуляции, поэтому после до 'print' ставим пару пробелов

Татьяна

Для того, чтобы определить какое значение будет принимать переменная Х, после выполнения фрагмента исходной программы, пройдем по этой программе вручную следующим образом:

1) а: =4, b: = 5, с: = 3.

2) If a > b then x: = a + b

4 > 5 - не верно, значит переходим на следующий шаг программы после ключевого слова else:

3) else begin

a: = b + c = 5 + 3 = 8; получили, что значение a теперь равняется 8.

x:= а - 3 * b = 8 - 3 * 5 = 8 - 15 = -7.

4) Поскольку следующим идет команда end, значит программа завершает и получаем значение x: = -7.

Таким образом правильный вариант ответа - г).

Объяснение:

ekater01806

Проверенные ответы содержат информацию, которая заслуживает доверия. На «Знаниях» вы найдёте миллионы решений, отмеченных самими пользователями как лучшие, но только проверка ответа нашими экспертами даёт гарантию его правильности.

{Задача сделана на языке паскаль, при Оформление сделана как для студенческой задачи

Если есть во пиши в личку

Задача:Написать программу на языке программирования Pascal, которая вводит с клавиатуры 4 числа и выводит результат вычисления спо следующей схеме: "число1"−"число2"/"число3"+"число4"

Автор:

Дата:  }

 var  x1, x2, x3, x4: integer;

f:real;

begin

//Ввод

writeln('введите 1 число');

readln(x1);  

writeln('введите 2 число');

readln(x2);  

writeln('введите 3 число');

readln(x3);  

writeln('введите 4 число');

readln(x4); //решение

f:=(x1-x2)/(x3+x4);  

//вывод

writeln (f);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Python написать программу, которая запрашивает число, и если оно 4597 печатает "как хорошо" иначе "иди, учи информатику"
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

iraira761
Долбоебков_Алексей27
aleksvasin
ivanpetrovichru1801
yusliva
nsmmkrtchyan
Nikolaevich1534
BorgovichOA
Светлана-Тигран
jstepanova
anusha33325
Polina780
dmitrijku
ievlevasnezhana7
blizzardtap641
▲