Plyushchik_Nikita
?>

Написать программу, которая выводит сообщения о цифрах 3х значного числа. первая цифра - 3 вторая цифра - 4 третья цифра - 5

Информатика

Ответы

yuliyaminullina

go

{started use:a, b, c};

algost

{by x,x,x use "yes"}

but "no";

stop

loading;

Объяснение:

Использованный язык программирования Swift

D.Yu. Polina1703
1.
var
  s: string;
  i, count: integer;
begin
  writeln('Vvedite stroky: ');
  readln(s);
  for i := 1 to length(s) - 2 do
    if copy(s, i, 3) = 'abc' then
      count := count + 1;
  writeln('Kol-vo: ', count);
end.
2.
var
  s1, s2: string;
  i, len1, len2: integer;
begin
  writeln('Vvedite stroky 1: ');
  readln(s1);
  writeln('Vvedite stroky 2: ');
  readln(s2);
  len1 := length(s1);
  len2 := length(s2);
  if len1 > len2 then writeln('1 stroka dlinnee')
  else if len1 < len2 then writeln('2 stroka dlinnee')
  else writeln('dlini strok ravnie')
end.
3.
var
  s1, s2, s3: string;
begin
  writeln('Vvedite stroky 1: ');
  readln(s1);
  writeln('Vvedite stroky 2: ');
  readln(s2);
  s3 := s1[1] + s1[2] + s2[1] + s2[2];
  writeln('Novaja stroka: ', s3);
end.
Vladimir-Tamara1359
Var   a: array[1..20,1..20] of integer;   n,m,i,j,min,jm,x: integer; begin   randomize;   write('Введите размеры массива: ');   readln(n,m);   writeln('Исходный массив:');   for i:=1 to n do   begin     for j:=1 to m do     begin       a[i,j]:=random(19)-9;       write(a[i,j]:4);     end;     writeln;   end;   min:=0;   for i:=1 to n do min:=min+a[i,1];   writeln('Сумма элементов 1-го столбца = ',min);   jm:=1;   for j:=2 to m do   begin     x:=0;     for i:=1 to n do       x:=x+a[i,j];     writeln('Сумма элементов ',j,'-го столбца = ',x);     if x<min then     begin       min:=x;       jm:=j;     end;   end;   writeln('Минимальная сумма в ',jm,'-м столбце');   writeln('Полученный массив:');   for i:=1 to n do   begin     for j:=1 to m do     begin       if j<>jm then a[i,j]:=a[i,jm];     write(a[i,j]:4);     end;     writeln;   end;   readln; end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая выводит сообщения о цифрах 3х значного числа. первая цифра - 3 вторая цифра - 4 третья цифра - 5
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

xachen
mishagoride885
innavinogradova1385
Хромов1501
Berezovskaya
Melsan19914239
kotocafe45
Baidina
БашуроваОльга369
lpcck2212
dariagromova54
тахирович_Игорь581
татьяна1245
moidela87
N-odes-art-school410
▲