alexandrxzx09
?>

Написать программу, которая определяет сумму выручки киоска мороженого за день. известно, что ежедневно совершается 50 покупок, стоимость мороженого варьируется от 20 до 200 рублей. продажи случайными числами. в паскале abc

Информатика

Ответы

Vladimirovich58
1. Вот так это пишется с функцией

// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
function IsPrime(n:integer):boolean;
begin
  if n<4 then Result:=True
  else begin
    var found:= (n mod 2 = 0);
    var p:=3;
    while (not found) and (sqr(p)<=n) do
      begin
      found:=(n mod p = 0);
      p+=2
      end;
    Result:=not found
    end
end;

begin
  Writeln('k=',ArrRandom(ReadInteger('n='),1,999).Println.
    Where(x->IsPrime(x)).Count)
end.

Тестовое решение:
n= 10
401 828 780 444 694 965 23 341 673 875
k=3

2. А вот так это пишется с процедурой

// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
procedure IsPrime(n:integer; var res:boolean);
begin
  if n<4 then res:=True
  else begin
    var found:= (n mod 2 = 0);
    var p:=3;
    while (not found) and (sqr(p)<=n) do
      begin
      found:=(n mod p = 0);
      p+=2
      end;
    res:=not found
    end
end;

begin
  var a:=ArrRandom(ReadInteger('n='),1,999); a.Println;
  var k:=0;
  var prime:boolean;
  foreach var e in a do begin
    IsPrime(e,prime);
    if Prime then Inc(k)
    end;
  Writeln('k=',k)
end.

Тестовое решение:
n= 12
199 43 71 365 417 904 170 212 694 103 161 689
k=4
borisowaew

Объяснение:

1) В текущее активное окно (которое находится над всеми)

2) На панели состояния или панели инструментов в зависимости от системы

3) Откатится к последнему сохранению, так как отчистится ОЗУ

4) Да, это и есть текст (правда если это будет внешний код, то можно в этом сомневается, но в основном - да)

5) папка - папка, находящаяся в корне или в каталоге (какой - то диск), а вложенная папка - папка в папке

6) Сходство : обе сохраняют документ

Различие: сохранить как сохраняет как новый документ в новый путь с новым названием и возможно с новым расширением, а сохранить просто обновляет файл на диске

7) я не знаю, что вам задал учитель, скажите, сделаем!

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая определяет сумму выручки киоска мороженого за день. известно, что ежедневно совершается 50 покупок, стоимость мороженого варьируется от 20 до 200 рублей. продажи случайными числами. в паскале abc
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

info126
Конычева-музей&quot;260
Sukharev-Achkasov
andrewshilin1334
МАМОНОВА-андрей
missimeri
Викторовна
Kalugin Vyacheslavovna605
rimmatrotskaia303
Shumnova42
NikolaevichIP1136
mnkrasnova
NataliaBerezovskaya33
titovass9
d5806252