margusha1974
?>

Напишите программу на паскале, которая считывает число n, а затем ещё n чисел . выведите сумму индексов чисел , оканчивающихся на 7 , нумерация с 1.

Информатика

Ответы

vahmistrova

PascalABC.NET

begin

 var n := ReadInteger;

 var a := ReadArrInteger(n);

 var s := 0;

 for var i := 0 to a.High do

   if Abs(a[i]) mod 10 = 7 then

     s += i + 1;

 s.Println;    

end.

nataliarogacheva

Program Scheme;

Var xn,xk,dx,x,s,p,k,y: Extended;

Label rep;

Begin

write('Enter xn: ');

readln(xn);

write('Enter xk: ');

readln(xk);

write('Enter dx: ');

readln(dx);

s:=0; p:=1; x:=xn; k:=0;

rep:

If x <= xk then

 Begin

  y:=exp(sin(x))*cos(x);

  writeln('x = ',x:0:3, '  y = ', y:0:3);

  if y >= 0 then

  s:=s+y;

  if y <> 0 then

  p:=p*y;

  x:=x+dx;

  goto rep;

 End

else

 Begin

  writeln('S = ', s:0:3, ' P = ', p:0:3, ' k = ', k:0:3);

  exit;

 End;

End.

Объяснение: Если есть вопросы, пишите в лс.

Ingakazakova
Var
a,b,c: integer;
x,y,z:string;
begin
x:='рубль';
y:='рубля';
z:='рублей';
writeln('Сколько стоит метр ткани?(в рублях)');
readln(a); writeln('Сколько вы хотите купить ткани?(в метрах квадратных)'); readln(b);
c:=a*b;
if c=1 then
begin
writeln('Это будет стоить',' ',c,' ',x);
end;
if (2<=c) and (c<=4) then
begin
writeln('Это будет стоить',' ',c,' ',y);
end;
if (5 <= c) and(c <= 1000000) then
begin
writeln('Это будет стоить',' ',c,' ',z);
end;
end.

В зависимости от результата программа будет выводить разное окончание.
1 рубль;
3 рубля;
100 рублей.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на паскале, которая считывает число n, а затем ещё n чисел . выведите сумму индексов чисел , оканчивающихся на 7 , нумерация с 1.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

diannaevaaa
marinarodina90
zbellatriks
beaevgen711
Zolotnik974620
bogdanyukn562
azarovaelena19812
спец387
pelagia-kola2658
heodbxbbshe
vitbond12
Mnatsovna
voloshin238
georgegradoff122
dianabuchkina
▲