Galina_Yurevna
?>

Напишите программу на языке паскаль. автомобиль шкода едет со скоростью 180 кмч/ч, автомобиль audi со скоростью 98 км/ч. кто быстрее доберётся до города в из города а? , !

Информатика

Ответы

yulyatmb
1)var a,b,c,a1,b1,c1,s:integer;
begin
writeln('Введите количество часов в первом моменте времени');
readln(a);
writeln('Введите количество минут в первом моменте времени');
readln(b);
writeln('Введите количество секунд в первом моменте времени');
readln(c);
writeln('Введите количество часов во втором моменте времени');
readln(a1);
writeln('Введите количество минут во втором моменте времени');
readln(b1);
writeln('Введите количество секунд во втором моменте времени');
readln(c1);
s:=abs(a*3600+b*60+c-a1*3600-b1*60-c1);
writeln(s,' секунд');
end.
2)var a,b:integer;
s:real;
begin
writeln('Введите первое число');
readln(a);
writeln('Введите второе число');
readln(b);
if (a+b) mod 2 =0 then s:=a*b
else s:= a/b;
writeln(s);
end.
3)var b,s,n:real;
begin
writeln('Введите количество часов');
readln(n);
n:=n/3;
s:=2*power(2,(n-1));
writeln(s,' амёб');
end.
4)var a:array[1..7]of integer;
i:integer;
begin
for i:=1 to 7 do
begin
a[i]:=random(11);
writeln('a[',i,']= ',a[i]);
end;
end.
evrotrastop64
1)var a,b,c,a1,b1,c1,s:integer;
begin
writeln('Введите количество часов в первом моменте времени');
readln(a);
writeln('Введите количество минут в первом моменте времени');
readln(b);
writeln('Введите количество секунд в первом моменте времени');
readln(c);
writeln('Введите количество часов во втором моменте времени');
readln(a1);
writeln('Введите количество минут во втором моменте времени');
readln(b1);
writeln('Введите количество секунд во втором моменте времени');
readln(c1);
s:=abs(a*3600+b*60+c-a1*3600-b1*60-c1);
writeln(s,' секунд');
end.
2)var a,b:integer;
s:real;
begin
writeln('Введите первое число');
readln(a);
writeln('Введите второе число');
readln(b);
if (a+b) mod 2 =0 then s:=a*b
else s:= a/b;
writeln(s);
end.
3)var b,s,n:real;
begin
writeln('Введите количество часов');
readln(n);
n:=n/3;
s:=2*power(2,(n-1));
writeln(s,' амёб');
end.
4)var a:array[1..7]of integer;
i:integer;
begin
for i:=1 to 7 do
begin
a[i]:=random(11);
writeln('a[',i,']= ',a[i]);
end;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на языке паскаль. автомобиль шкода едет со скоростью 180 кмч/ч, автомобиль audi со скоростью 98 км/ч. кто быстрее доберётся до города в из города а? , !
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ka-shop
галина
алексей-Ветошкин
m79857860146895
svetlana-ladyga
slastena69678
kozhevniks
Наталья_Васищев
Карева Даниил1537
deniskotvitsky56
Fruktova Gazaryan
lazarevaavrora
kozak8824
Zashchitin Denis
mishanay301csfp