Chistov9721209
?>

Исполнитель робот действует в следующей обстановке для робота составлена программа

Информатика

Ответы

smint056950
Var x,y,z:integer; {описание переменных и их типа}
begin
writeln ('введи два числа'); {Вывод на экран сообщения-подсказки}
readln (x,y); {считывание переменных}
if x<0 then                      {проверка условия.}
  if y>x then z:=y             {если условие истинно, то мы ищем большее из х и у. если                                        у больше, то присваиваем z значение у}
           else z:=x             {если же больше х, то присваиваем его значение}
        else                        {если условие ложно}
           if y>x then z:=x     {то мы ищем меньшее из х и у. если                                                                           у больше, то присваиваем z значение х}
                    else z:=y;     {если же больше х, то присваиваем значение у}
writeln (z);                        {вывод результата на экран}
end.                                 {конец программы}
fox-cab3444
Const n=7; m=8;
Var a:array[1..n,1..m] of integer;
i,j,x,y,min:integer;
begin
for i:=1 to n do begin
for j:=1 to m do begin
a[i,j]:=random(21)-10;
write(a[i,j]:4);
end;
writeln;
end;
min:=a[1,1];
x:=1;
y:=1;
for i:=1 to n do
for j;=1 to m do 
if a[i,j]<min then begin
min:=a[i,j];
x:=i;
y:=j;
end;
writeln ('минимальный элемент=',min,' он находился: ',x,',',y);
a[x,y]:=100;
for i:=1 to n do begin
for j:=1 to n do 
write (a[i,j]:4);
writeln;
end;
end.

3.Var s:string;
i:integer;
begin
writeln('Введи строку');
readln (s);
for i:=1 to length(s) do
if (s[i]='Е') or (s[i]='е') then delete(s,i,1);
writeln(s);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Исполнитель робот действует в следующей обстановке для робота составлена программа
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Melnik Kaveshnikova1746
Ионов202
akakne86
Marina281
Михайлов
Валуева
magichands68
Nv-444
valueva260860
office3
Serafim
mbykovskiy
myglassi26
Aleksandrovich-Mayatskikh
alenaya69918