новые версии
Создание блок-схемы
Запустите Visio.
Выберите категорию Блок-схема.
Дважды щелкните значок блок-схема.
Для каждого этапа документируемого процесса перетащите в документ соответствующую фигуру блок-схемы.
Чтобы соединить элементы блок-схемы, наведите указатель мыши на первую фигуру, и щелкните стрелку, указывающую на фигуру, с которой требуется создать соединение. Если вторая фигура находится не рядом с первой, необходимо перетащить маленькую стрелку к центру второй фигуры.
Чтобы добавить текст для фигуры или соединительной линии, выделите ее и введите текст. По завершении ввода текста щелкните в пустой области страницы.
Чтобы изменить направление стрелки соединительной линии, выберите соединение, а затем на вкладке Фигура в группе Стили фигур щелкните пункт Линия, наведите указатель на пункт Стрелки и выберите нужное направление и вид стрелки.
Автоматическое выравнивание и интервалы
Нажмите сочетание клавиш CTRL+A, чтобы выбрать все объекты на странице.
На вкладке Главная в группе Упорядочение нажмите кнопку Положение и выберите пункт Автовыравнивание и определение интервалов.
Если это не привело к нужному результату, отмените ее, нажав сочетание клавиш CTRL+Z, и воспользуйтесь другими параметрами меню кнопок Выравнивание и Положение.
Пример блок-схемы, представляющей процесс предложения
Что представляют блок-схемы
При открытии шаблона блок-схема открывается набор элементов Фигуры блок-схемы. Каждая фигура в этом наборе представляет собой тот или иной этап процесса. Но фигуры не имеют какого-то универсального смысла, их значение определяется создателями и пользователями блок-схем. В большинстве блок-схем используется три или четыре вида фигур, и этот диапазон расширяется только по специфической необходимости.
При этом названия фигур в Visio указывают на их применение. Ниже описаны наиболее рас фигуры.
Начало/конец. Эту фигуру следует использовать для представления первого и последнего этапа процесса.
Фигура "Начало/Завершение"
Процесс. Фигура представляет собой стандартный этап процесса. Это одна из наиболее часто используемых фигур в любом процессе.
Фигура "Процесс"
Решение. Эта фигура используется в точке, где выбор следующего этапа зависит от принятого решения. Вариантов может быть несколько, но чаще всего их два: "да" и "нет".
Фигура "Решение"
Подпроцесс. Эту фигуру следует использовать для представления ряда этапов, которые в совокупности образуют подпроцесс, определенный в другом месте (часто на другой странице того же документа). Такой подход удобен, если блок-схема получается слишком большой и сложной.
Фигура "Заранее определенный процесс"
Документ. Эта фигура представляет этап, на котором создается документ.
Фигура "Документ"
Данные. Эта фигура указывает, что данные поступают в процесс или покидают его. Также эта фигура может представлять материалы. Иногда ее называют фигурой "Ввод/Вывод".
Фигура "Данные"
Ссылка на текущую страницу. Маленький круг показывает, что следующий (предыдущий) этап находится в другом месте документа. Эта фигура особенно полезна на больших блок-схемах, где в противном случае пришлось бы использовать длинный соединитель, который сложно отследить.
Фигура "Ссылка на текущую страницу"
Ссылка на другую страницу. При размещении этой фигуры на странице открывается диалоговое окно, в котором можно создать набор гиперссылок между двумя страницами блок-схемы или между фигурой "Подпроцесс" и отдельной страницей блок-схемы, на которой показаны этапы этого подпроцесса.
Фигура "Ссылка на другую страницу"
Поделитесь своими знаниями, ответьте на вопрос:
Составьте программу для вычисления элементов матрицы y по известным элементам вектора x.
1)
var mas: array[1..10] of real = {.,.,}; // перечисление элементов массива, который дан по условию задания
var counter: integer;
begin
for i:= 1 to 10 do
begin
if mas[i]<0 then counter:=counter+1;
end;
end.
2)
var mas: array[1..5] of integer = {.,.,}; // перечисление элементов массива, который дан по условию задания
var counter: integer;
begin
for i:= 1 to 5 do
begin
if (mas[i]>0) and (i mod 2 = 0) then counter:=counter+1;
end;
end.
3)
var mas: array[1..15] of integer = {.,.,}; // перечисление элементов массива, который дан по условию задания
var counter: integer;
begin
for i:= 1 to 15 do
begin
if (mas[i]>5) and (i mod 2 = 0) then counter:=counter+1;
end;
end.
4)
var mas: array[1..15] of integer;
var counter: integer;
begin
for i:= 1 to 15 do
begin
mas[i] = random(20) - 5;
end;
for i:= 1 to 15 do
begin
writeln(mas[i]);
end;
for i:= 1 to 15 do
begin
if (mas[i]>0) then counter:=counter+1;
end;
end.
5)
var mas: array[1..7] of real = {.,.,}; // перечисление элементов массива, который дан по условию задания
var counter: integer;
begin
for i:= 1 to 7 do
begin
readln(mas[i]);
end;
for i:= 1 to 7 do
begin
if mas[i]>0 then mas[i]=0;
end;
for i:= 1 to 7 do
begin
writeln(mas[i]);
end;
end.
6)
var mas: array[1..10] of real = {.,.,}; // перечисление элементов массива, который дан по условию задания
var counter: integer;
var sum: real;
var average: real;
begin
for i:= 1 to 7 do
begin
readln(mas[i]);
end;
for i:= 1 to 7 do
begin
if mas[i]<0 then
begin
sum:=sum+mas[i];
counter:=counter+1;
end
end;
average:= sum/counter;
end.
Объяснение: