Lopatkin_Shchepak174
?>

Входные данные программа получает на вход два числа n и m, являющиеся числом строк и столбцов в массиве. далее во входном потоке идет n строк по m чисел, являющихся элементами массива. выходные данные программа должна вывести 2 числа: сумму и номер строки, для которой эта сумма достигается. если таких строк несколько, то выводится номер наименьшей из них. не забудьте, что нумерация строк (спортсменов) начинается с 0. примеры входные данные 2 2 5 4 3 5 выходные данные 9 0

Информатика

Ответы

Газинурович

c++ / gcc 7.3.0

#include <iostream>

#include <algorithm>

#include <vector>

int main()

{

   unsigned short int N;

   unsigned int result = 0;

   std::cin >> N;


   std::vector<unsigned short int> arr;


   while(true)

   {

       unsigned short int tmp;

       std::cin >> tmp;

       if(tmp != 0)

           arr.push_back(tmp);

       break;

   }

   std::for_each(arr.cbegin(), arr.cend(), [&result](auto& var)

   {

       if(var > 99 && var < 1000 && (var % 4 == 0))

           result += var;

   });

   std::cout << result << std::endl;

   return 0;

}



Напишите программу, которая в последовательности натуральных чисел определяет сумму трёхзначных чисе
xobby18

mas = []

for i in range(1000):

   n = int(input())

   while ((0 > n) or (n > 300)):

       print("Enter n in interval: 0 < n < 300")

       n = int(input())

   if (n == 0):

       break

   else :

       mas.append(n)

#В даном цыкле мы заполнили масив mas[] всеми елементами, которые вводились из клавиатуры и подпадали под определение - 0 < n < 300

print("1 (mas)")

print(*mas)

print()

mas_peregon = []

for i in range(len(mas)):

   if ((mas[i]//100) > 0):

       mas_peregon.append(mas[i])

   else :

       continue

#В даном цыкле мы заполнили масив mas_peregon[] всеми елементами, которые есть в масиве mas[] и являются трехцыфовыми числами

print("2 (mas_peregon)")

print(*mas_peregon)

print()

mas_kr_4 = []

for i in range(len(mas_peregon)):

   if ((mas_peregon[i]%4) == 0):

       mas_kr_4.append(mas_peregon[i])

   else :

       continue

#В даном цыкле мы заполнили масив mas_kr_4[] всеми елементами, которые есть в масиве mas_peregon[] и есть кратными четырём

print("3 (mas_kr_4)")

print(*mas_kr_4)

print()

s = 0

for i in range(len(mas_kr_4)):

   s = s + mas_kr_4[i]

#В даном цыкле мы нашли суму елементов масива mas_kr_4

print(s)

Объяснение:

Можно было сделать на один цыкл меньше, но я уже не стал исправлять. Кстати, реализовано на Python 3

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Входные данные программа получает на вход два числа n и m, являющиеся числом строк и столбцов в массиве. далее во входном потоке идет n строк по m чисел, являющихся элементами массива. выходные данные программа должна вывести 2 числа: сумму и номер строки, для которой эта сумма достигается. если таких строк несколько, то выводится номер наименьшей из них. не забудьте, что нумерация строк (спортсменов) начинается с 0. примеры входные данные 2 2 5 4 3 5 выходные данные 9 0
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kirill81
ekaizer
Gennadevna_Baidalina131
tteplovoz3789
ninaandreeva3179
alisapavlushina
Nikolai_oksana
ajsklan
krimenu5033
delo1005
Vetroff-11
sergeevich
movlam11
ale-protasov
buyamel
▲