airlineskozlova69
?>

написать программу, заполняющую массив из 300 целых чисел из файла «file.txt», который лежит в папки «». на основе первой программы, найти сумму этих чисел на основе первой программы, найти произведение этих чисел (попытайтесь объяснить, почему при сложении в целое число получается «0», а в переменную типа read – бесконечность) на основе первой программы, найти среднее арифметическое этих чисел большее из этих чисел подсчитать количество положительных чисел подсчитать количество четных чисел подсчитать количество чисел, делящихся на 4 нацело отсортировать массив по возрастанию на основе первой программы, вывести числа, которые повторяются более одного раза 1) assign… reset… for i: =1 to 300 do read(f, a[i]); close… 2) s: =0; for… s: =s+a[i] 3) s: =0; for… s: =s*a[i] 4) s: =0; for… s: =s+a[i] sr: =s/i 5) max: =a[i] for… if max 6) k: =0; for… if a[i]> 0 then k: =k+1 7) if odd(a[i]) then k: =k+1 8) ifa[i] mod 4 = 0 then k: =k+1 содержимое файла: -46 13 -23 53 97 19 -34 28 -10 -47 7 65 89 36 -26 100 -47 -39 3 49 -13 -40 -36 7 62 40 -47 -22 -41 47 -46 -11 66 -28 97 -46 98 41 100 -36 72 88 80 8 43 -47 90 85 34 64 -21 -25 12 -47 49 94 -1 71 92 7 16 88 18 43 100 -32 100 67 39 -30 -48 12 -38 -12 78 -1 -19 57 65 58 50 -32 44 -5 18 80 78 62 24 -47 55 -23 50 42 49 84 19 -14 8 24 -46 -27 -4 14 62 68 -37 -27 -24 -1 62 43 -45 -17 57 -3 -7 -27 -25 -30 -10 -13 -8 36 15 75 62 20 40 94 81 95 -2 -10 54 27 73 -20 34 50 66 54 36 -26 -9 -38 -28 17 86 1 40 -4 -39 -12 -17 68 81 60 99 87 -45 43 33 -18 19 67 -6 65 30 -20 25 -37 39 25 4 37 52 -32 -6 2 53 -6 35 -11 3 34 84 -40 -43 86 46 -38 -19 47 44 -28 -29 3 56 24 69 7 88 55 77 27 58 36 84 47 -35 63 16 47 -16 61 -42 -6 80 86 84 -17 58 44 34 12 82 92 81 -19 15 -2 13 70 34 -5 7 80 13 76 77 -2 -24 10 71 84 46 35 13 83 -37 77 24 71 41 35 50 -7 -29 14 45 66 55 53 -18 68 -1 46 -37 89 4 -21 82 -47 -42 35 -43 -2 74 50 67 -3 29 98 -33 39 74 43 -22 99 46 -36 59 99 -19 -39 43 24 -22 -48

Информатика

Ответы

irinaastapova2011

ответ:

работает с e1, но в e2 выдает time limit exceeded на 57 тесте

объяснение:

m, n = map(int,

bank = []

bull = []

for i in range(m):

    bank.append(list(map(int,

for i in range(n):

    bull.append(list(map(int,

shoted = [true] * m

ns = [-1] * n

for i in range(n):

    for j in range(m):

        if bank[j][0] < = bull[i][0] < = bank[j][2] and bank[j][1] < = bull[i][1] < = bank[j][3] and shoted[j]:

            shoted[j] = false

            ns[i] = j + 1

            break

for k in ns:

    print(k, end=' ')

Вячеславовна_Сагитович
//где-то не закрыла begin end
var A:array [1..40] of integer;
sa,s3,s10,k,i: integer;
begin
sa:=0;
s10:=0;
s3:=0;
k:=0;
writeln('исходные значения');
for i:=1 to 40 do
begin
 A[i]:= random(21);
write(A[i],'')
end;
writeln;
for i:=1 to 40 do
 begin
 if A[i]mod 2<>0 then
begin
 sa:=sa+A[i];
k:=k+1;
if A[i]<10 then s10:=s10+A[i];
if A[i] mod 3=0 then
s3:=s3+A[i];                                     //здесь было странное выражение   
end;
end;                                                  //здесь
writeln('среднее арефмитическое нечетных чисел',sa/k:5:0);
writeln('сумма чисел, не превышающих', s10);
writeln('сумма чисел, кратных трем', s3);
End.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

написать программу, заполняющую массив из 300 целых чисел из файла «file.txt», который лежит в папки «». на основе первой программы, найти сумму этих чисел на основе первой программы, найти произведение этих чисел (попытайтесь объяснить, почему при сложении в целое число получается «0», а в переменную типа read – бесконечность) на основе первой программы, найти среднее арифметическое этих чисел большее из этих чисел подсчитать количество положительных чисел подсчитать количество четных чисел подсчитать количество чисел, делящихся на 4 нацело отсортировать массив по возрастанию на основе первой программы, вывести числа, которые повторяются более одного раза 1) assign… reset… for i: =1 to 300 do read(f, a[i]); close… 2) s: =0; for… s: =s+a[i] 3) s: =0; for… s: =s*a[i] 4) s: =0; for… s: =s+a[i] sr: =s/i 5) max: =a[i] for… if max 6) k: =0; for… if a[i]> 0 then k: =k+1 7) if odd(a[i]) then k: =k+1 8) ifa[i] mod 4 = 0 then k: =k+1 содержимое файла: -46 13 -23 53 97 19 -34 28 -10 -47 7 65 89 36 -26 100 -47 -39 3 49 -13 -40 -36 7 62 40 -47 -22 -41 47 -46 -11 66 -28 97 -46 98 41 100 -36 72 88 80 8 43 -47 90 85 34 64 -21 -25 12 -47 49 94 -1 71 92 7 16 88 18 43 100 -32 100 67 39 -30 -48 12 -38 -12 78 -1 -19 57 65 58 50 -32 44 -5 18 80 78 62 24 -47 55 -23 50 42 49 84 19 -14 8 24 -46 -27 -4 14 62 68 -37 -27 -24 -1 62 43 -45 -17 57 -3 -7 -27 -25 -30 -10 -13 -8 36 15 75 62 20 40 94 81 95 -2 -10 54 27 73 -20 34 50 66 54 36 -26 -9 -38 -28 17 86 1 40 -4 -39 -12 -17 68 81 60 99 87 -45 43 33 -18 19 67 -6 65 30 -20 25 -37 39 25 4 37 52 -32 -6 2 53 -6 35 -11 3 34 84 -40 -43 86 46 -38 -19 47 44 -28 -29 3 56 24 69 7 88 55 77 27 58 36 84 47 -35 63 16 47 -16 61 -42 -6 80 86 84 -17 58 44 34 12 82 92 81 -19 15 -2 13 70 34 -5 7 80 13 76 77 -2 -24 10 71 84 46 35 13 83 -37 77 24 71 41 35 50 -7 -29 14 45 66 55 53 -18 68 -1 46 -37 89 4 -21 82 -47 -42 35 -43 -2 74 50 67 -3 29 98 -33 39 74 43 -22 99 46 -36 59 99 -19 -39 43 24 -22 -48
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vasenkova1981
sergeykvik13
ziyaevak
Mariya694
ALLA1868
eoils-info
Ulianev77
Евгения-Валерий
dimari81
nataljatchetvertnova
vakhitov100961
papushinrv4985
НиканоровСалиев675
Евгений1286
ksyusatom19