Aleksandrovich1669
?>

Всистеме программирования abcpascal наберите текст для решения : составьте программу, подсчитывающую среднее арифметическое 10 элементов целочисленного массива. массив заполнить случайными элементами в диапазоне 0-50, вывести на экран с комментариями.

Информатика

Ответы

Sidunevgeniya

#include <iostream>

#include <cmath>

#include <vector>

using namespace std;

int main() {

vector<float> coordinates;

string a;

getline(cin, a);

string buffer;

for(int i = 0; i<a.length(); ++i) {

 if(a[i]!=' ') {

  buffer+=a[i];

 } if(a[i]==' '||i==a.length()-1) {

  if(buffer[buffer.length()-1]=='.') {

   buffer+="0";

  }  

  float num = stof(buffer);

  coordinates.push_back(num);

  buffer = "";

 }

}

if(coordinates.size()!=4) {

 cout << "wrong data. example: 1.1 2.2 3.3 4.4";

}

float result;

int temp1, temp2, temp3, temp4;

temp1 = coordinates[0]-coordinates[2];

temp2 = coordinates[1]-coordinates[3];

temp1 = temp1 * temp1;

temp2 = temp2 * temp2;

temp3 = temp1 + temp2;

result = sqrt(temp3);

cout << result;

}

uglichwatch
Питаются кагуаны исключительно растительной пищей — листвой, почками, цветами и деревьев. большую часть рациона составляют молодые листья.  редко вокруг какого животного ведется столько споров, как вокруг кагуанов. это животное, размером с кошку, одни причисляют к «летающим» землеройкам, другие к лемурам, а некоторые выделяют когуана вообще в отдельный отряд. внешне, особенно мордочкой, он действительно похож на лемура, а вот зубы типичны для грызунов.  самая же отличительная черта когуана – перепонка, с которой он летает. перепонка натянута от подбородка через концы лап до кончика не длинного хвоста и представляет собой этакий парашют. кстати, парашют у кагуаны самый большой среди «летающих» животных (кроме птиц и летающих мышей к полетам причастны белки-летяги, сумчатые летяги, обезьяны колобус, летающие ящерицы или драконы, а также летающие лягушки и даже рыбы) 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Всистеме программирования abcpascal наберите текст для решения : составьте программу, подсчитывающую среднее арифметическое 10 элементов целочисленного массива. массив заполнить случайными элементами в диапазоне 0-50, вывести на экран с комментариями.
Ваше имя (никнейм)*
Email*
Комментарий*