Кашихина
?>

Напишите программу в python, вычисляющую наибольший общий делитель двух натуральных чисел, используя алгоритм евклида.

Информатика

Ответы

ElenaEgorova1988576

chislo1 = int(input("Введите число а "))

chislo2 = int(input("Введите число b "))

while chislo1 != 0 and chislo2 != 0:

   if chislo1 > chislo2:

       chislo1 = chislo1 % chislo2

   else:

       chislo2 = chislo2  % chislo1

print(chislo1 + chislo2)

Объяснение:

НОД числа:

берутся два числа. большее число = остаток от деления большего на меньшее. Затем опять большее число (может быть уже второе) = остаток от деления большего на меньшее, и так до тех пор, пока одно из них не станет равно 0. И выводится большее число. В случае если числа равны друг другу, находится остаток от деления второго числа на первое: 0, и выводится первое число. Т.е всё работает.

Klicheva_Ermachenkova1536

Давайте узнаем, что такое алгоритм, и какие существуют виды его исполнителей.

Алгоритм – это описание последовательности шагов в решении задачи, приводящих от исходных данных к требуемому результату.

Исполнитель - это объект выполнять алгоритмы с набора команд

Процесс создания алгоритмов называется –алгоритмизацией.

Всякий алгоритм составляется в расчете на определенного исполнителя. Им может быть человек, робот, компьютер и др.

Исполнитель алгоритма – это человек или автоматическое устройство, которое воспринимать и исполнять алгоритм.

Запишите исполнителей для приведённых ниже видов работ:

Уборка мусора во дворе – дворник

Перевозка пассажиров в поезде – машинист

Приём экзаменов в школе – учитель

Приготовление еды в ресторане – повар

Выполнение домашнего задания – ученик

Чтобы составить алгоритм для исполнителя, нужно знать, какие команды исполнитель может понять и исполнить, а какие нет.

Система команд исполнителя (СКИ) – это перечень элементарных предписаний (команд), которые исполнитель может исполнять.

Приведите еще примеры алгоритмов. ответы учащихся …

Из приведенных вами примеров видно, что мир алгоритмов очень разнообразен. Но, несмотря на это, можно выделить общие свойства, которыми обладает любой алгоритм.

Алгоритм обладает следующими свойствами:

Целенаправленность – любой алгоритм направлен на достижение определенной цели. Чаще всего целью алгоритма является получение результата при решении какой-нибудь задачи.

Дискретность– алгоритм состоит из элементарных предписаний (команд).

Понятность – элементарные предписания (команды) алгоритма должны быть точно сформулированы и однозначно понятны исполнителю, а исполнитель должен быть в состоянии их выполнить.

Однозначность – после исполнения очередного элементарного предписания (команды) исполнителю точно определено, что делать дальше.

Массовость – алгоритм можно использовать для решения той же задачи при других допустимых исходных данных.

palchiknr

Чтобы дать 400 единицам техники уникальные номера, нам понадобится использовать 9 бит памяти занимает каждый номер. Разберёмся, почему:

Есть формула N<=2^i, где N - количество объектов, которым надо дать уникальные "коды", а i - длина кода

В нашей задаче N=400

400<=2^i - ближайшее значение i, являющееся решением неравенства будет 9:

400<=2^9

400<=512

Делаем вывод: каждый номер будет записан в 9 битах.

У нас проехало 60 машин, номер каждый весит 9 бит, значит вся информация весит 9*60 бит = 540 бит

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу в python, вычисляющую наибольший общий делитель двух натуральных чисел, используя алгоритм евклида.
Ваше имя (никнейм)*
Email*
Комментарий*