achernakov
?>

60 . на с++ сжатие массива напишите программу, которая выполняет "сжатие массива" – переставляет все нулевые элементы в конец массива. при этом все ненулевые элементы располагаются в начале массива в том же порядке. входные данные первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. гарантируется, что 0 < n ≤ 1 . выходные данные программа должна вывести в одну строчку все элементы получившегося массива, разделив их пробелами. примеры входные данные 6 1 0 2 0 3 4 выходные данные 1 2 3 4 0 0

Информатика

Ответы

filternovo

#include <iostream>

using namespace std;

int main()

{

setlocale(LC_ALL, "Rus");

int n, j;

cout << "введите длину массива ";cin >> n;

int* A = new int[n];

cout << "Введите массив " << endl;

for (int i = 0; i < n; i++) //ввод массива

{

 cin >> A[i];

}

for (int i = n - 1; i >= 0; i--)

{

 j = i;

 while (A[j] == 0 && A[1 + j] != 0 && j + 1 < n)

 {

  int tmp = A[j + 1];

  A[j + 1] = A[j];

  A[j] = tmp;

  j++;

 }

}

cout << "новый массив ";

for (int i = 0; i < n; i++)

{

 cout << A[i]<<" ";

}

delete[] A;

return 0;

}

olesya-kwas

import math

a = int(input("Введите коэффициент a"))

b = int(input("Введите коэффициент b"))

c = int(input("Введите коэффициент c"))

if (b ** 2 - 4 * a * c == 0):

   print("Уравнение имеет всего 1 корень", -b / (2 * a))

if (b ** 2 - 4 * a * c > 0):

   x1 = (- b + math.sqrt(b ** 2 - 4 * a * c)) / (2 * a)

   x2 = (- b - math.sqrt(b ** 2 - 4 * a * c)) / (2 * a)

   print("Уравнение имеет 2 корня", x1, x2)

if (b ** 2 - 4 * a * c < 0):

   print("Уравнение не имеет корней в действительных числах")

mpityk

Мультиме́діа (лат. Multum + Medium) — комбінування різних форм представлення інформації на одному носієві, наприклад текстової, звукової і графічної, або, останнім часом все частіше — анімації і відео. Характерна особливість мультимедійних об'єктів та продуктів — наявність гіперпосилання. Поняття, що означає сполучення звукових, відео, графічних, текстових і цифрових сигналів, а також нерухомих і рухомих образів і конструкцій. Так, мультимедійна база даних буде вміщувати текстову і образну інформацію, відеокліпи і таблиці, і все це має однаково легкий доступ. Мультимедійна послуга дозволяє користувачеві посилати, одержувати і використовувати будь-яку форму інформації, взаємозамінну і взаємодоповнюючі за бажанням.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

60 . на с++ сжатие массива напишите программу, которая выполняет "сжатие массива" – переставляет все нулевые элементы в конец массива. при этом все ненулевые элементы располагаются в начале массива в том же порядке. входные данные первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. гарантируется, что 0 < n ≤ 1 . выходные данные программа должна вывести в одну строчку все элементы получившегося массива, разделив их пробелами. примеры входные данные 6 1 0 2 0 3 4 выходные данные 1 2 3 4 0 0
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Агибалов428
Khiryanov
Анастасия1097
molodoychek
ВитальевичЕвгеньевич346
artem
Petrosienko_Larisa,1908
albina6580
pelagia-kola2658
Вадим
membuksdk
aamer9992680
Дмитрий_Пергамент669
ibird777
sky-elena712558